Ask Your Question
0

(Groovy | 12.04 | armv7l) Can't run 'roscore' nor 'roslaunch'

asked 2013-02-08 10:39:08 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Am installing ROS Groovy (from source) on a Tablet, whose Kernel is armv7l, and am having no luck when running the following command:

root@localhost:~# roscore
… logging to /home/ubuntu/.ros/log/---bunch-of-numbers----/roslaunch-localhost-22058.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.
Traceback (most recent call last):
  File "/opt/ros/groovy/lib/python2.7/dist-packages/roslaunch/__init__.py", line 265, in main
    p.start()
  File "/opt/ros/groovy/lib/python2.7/dist-packages/roslaunch/parent.py", line 257, in start
    self._start_infrastructure()
  File "/opt/ros/groovy/lib/python2.7/dist-packages/roslaunch/parent.py", line 206, in _start_infrastructure
    self._load_config()
  File "/opt/ros/groovy/lib/python2.7/dist-packages/roslaunch/parent.py", line 121, in _load_config
    self.config = roslaunch.config.load_config_default(self.roslaunch_files, self.port, verbose=self.verbose)
  File "/opt/ros/groovy/lib/python2.7/dist-packages/roslaunch/config.py", line 408, in load_config_default
    config.master.uri = rosgraph.network.create_local_xmlrpc_uri(port)
  File "/opt/ros/groovy/lib/python2.7/dist-packages/rosgraph/network.py", line 281, in create_local_xmlrpc_uri
    return 'http://%s:%s/'%(get_host_name(), port)
  File "/opt/ros/groovy/lib/python2.7/dist-packages/rosgraph/network.py", line 266, in get_hostname
    hostname = get_local_addresses()
  File "/opt/ros/groovy/lib/python2.7/dist-packages/rosgraph/network.py", line 173, in get_local_address
    addrs = get_local_addresses()
  File "/opt/ros/groovy/lib/python2.7/dist-packages/rosgraph/network.py", line 211, in get_local_addresses
    ifaces = ifaddrs.getifaddrs()
  File "/opt/ros/groovy/lib/python2.7/dist-packages/rosgraph/ifaddrs.py", line 147, in getifaddrs
    addr += "%02x:" % si.sll_addr[i]
IndexError: invalid index

My Environment is:

root@localhost:~# export | grep ROS
declare -x ROS_DISTRO="groovy"
declare -x ROS_ETC_DIR="/opt/ros/groovy/etc/ros"
declare -x ROS_MASTER_URI="h t t p://localhost:11311" <-- ROS ANSWERS DOES NOT LET ME PUBLISH LINKS
declare -x ROS_PACKAGE_PATH="/home/ubuntu/ros_ws:/opt/ros/groovy/share:/opt/ros/groovy/stacks"
declare -x ROS_ROOT="/opt/ros/groovy/share/ros"

I am connected through VNC and my interface configuration is:

root@localhost:~# ifconfig

only lo and eth0 appear.

Any suggestions to get roscore and roslaunch to work?

edit retag flag offensive close merge delete

Comments

Instead of [SOLVED]'ing you might post the resolution as an answer and mark it as accepted, that's how it works here.

felix k gravatar imagefelix k ( 2013-02-10 22:49:18 -0500 )edit

3 Answers

Sort by » oldest newest most voted
1

answered 2013-02-11 03:03:01 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Thanks to a comment from @adamantivm on github

I did the following and solved the issue:

sudo gedit /opt/ros/groovy/lib/python2.7/dist-packages/rosgraph/ifaddrs.py

go to line 112 and comment all the if ifa.ifa_addr: segment and add the following:

if ifa.ifa_addr is None:
     continue

This is for VNC connected products.

edit flag offensive delete link more

Comments

Hi, I am having the same problem and added that if statement to every 'ifaddrs.py' I could find, but this did not resolve my issue. Do you have another suggestion? Did you do anything else? ps. I am compiling on an Odroid (arm).

Hansg91 gravatar imageHansg91 ( 2013-02-12 03:22:47 -0500 )edit

For now, I commented out the AF_PACKET part in the python script. I don't think I need it ;)

Hansg91 gravatar imageHansg91 ( 2013-02-12 03:37:47 -0500 )edit

@amrivera can you clarify?

SL Remy gravatar imageSL Remy ( 2013-02-12 03:56:29 -0500 )edit
0

answered 2013-04-12 02:36:14 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I have tried to run ROS on my nexus 7 and met the same problem.I just recompiled the ros_comm package from source and replaced the /opt/ros/groovy/lib/python2.7 with compiled one.The version of rosgraph I download is release 1.9.44 . I don't think it's just the rosgraph that caused the problem.

edit flag offensive delete link more
0

answered 2013-02-15 10:27:46 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

The problematic file ifaddrs.py has been completely removed from rosgraph recently. You can either wait for the next release 1.9.42 of rosgraph or checkout the latest version from source and check if that works fine for you.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-02-08 10:39:08 -0500

Seen: 935 times

Last updated: Apr 12 '13