ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

sbpl installation problem

asked 2013-02-07 22:19:18 -0500

victorp gravatar image

updated 2013-02-07 22:24:27 -0500


I'm trying to install the sbpl package on Ubuntu 12.04. I installed ros-groovy-sbpl with apt-get but when I run :

$ rosmake sbpl_lattice_planner

I get the following output :

[ rosmake ] rosmake starting...                                                            
[ rosmake ] Packages requested are: ['sbpl_lattice_planner']                               
[ rosmake ] Logging to directory /home/<me>/.ros/rosmake/rosmake_output-20130208-110917
[ rosmake ] Expanded args ['sbpl_lattice_planner'] to:
[ rosmake ] WARNING: The following args could not be parsed as stacks or packages:   ['sbpl_lattice_planner']
[ rosmake ] ERROR: No arguments could be parsed into valid package or stack names.

I tried rosdep update and resourcing setup.bash already.

Thanks for any help.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2013-02-07 22:27:24 -0500

KruseT gravatar image

sbpl_lattice_planner is part of the navigation_experimental stack: You need to download that one into a rosbuild workspace to rosmake it.

ros-groovy-sbpl only contains the core c/c++ code.

If you followed instructions that seem to be missing information, please point us to the URL (mask it a bit so that you can post it).

edit flag offensive delete link more

Question Tools


Asked: 2013-02-07 22:19:18 -0500

Seen: 507 times

Last updated: Feb 07 '13