Ask Your Question
0

error in image_pipeline

asked 2013-02-06 07:42:17 -0500

jcc gravatar image

updated 2014-04-20 14:06:47 -0500

ngrennan gravatar image

Hi,

Today i tried to get the OpenCV 2.4.3 (With CUDA 5.0) working with ROS Fuerte. After i successful compile the OpenCV and test it i tried to compile a ROS program, but every program i compile (that uses the kinect) gives me this

make[3]: Entering directory '/home/joao/ros_workspace/sandbox/kinect_icp/build'
[ 50%] Building CXX object CMakeFiles/kinect_track.dir/src/GetFeaturePoints.o
[100%] Building CXX object CMakeFiles/kinect_track.dir/src/kinect_track.o
Linking CXX executable ../bin/kinect_track
/opt/ros/fuerte/stacks/image_pipeline/depth_image_proc/lib/libdepth_image_proc.so:     error: undefined reference to 'boost::signals::connection::~connection()'
/opt/ros/fuerte/stacks/image_pipeline/depth_image_proc/lib/libdepth_image_proc.so: error: undefined reference to 'boost::signals::connection::operator=(boost::signals::connection const&)'
collect2: ld returned 1 exit status
make[3]: *** [../bin/kinect_track] Error 1
make[3]: Leaving directory '/home/joao/ros_workspace/sandbox/kinect_icp/build'
make[2]: *** [CMakeFiles/kinect_track.dir/all] Error 2
make[2]: Leaving directory '/home/joao/ros_workspace/sandbox/kinect_icp/build'
make[1]: *** [all] Error 2
make[1]: Leaving directory '/home/joao/ros_workspace/sandbox/kinect_icp/build'
-------------------------------------------------------------------------------}

This is with and without using the Opencv. I also uninstall the Opencv 2.4.3, restart the pc and noting. I still get the same error...

Did i mess up with ROS or there was an update (that i didn't notice) that broke this?

How can i solve this?

Thanks

Edit:

I re-install every thing (even linux) and its the same thing. On a fresh install its every thing OK. This time i installed CUDA 4.2 and PCL 1.7 (ros version) and now this happens again. So i'm inclined to say its a problem related to CUDA (the common thing between the two "experiences") I installed CUDA according to https://help.ubuntu.com/community/Cuda

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-02-06 18:20:08 -0500

snakehaihai gravatar image

could be using namespace issue. Did you build your opencv directly with ROS in the CMAKE? I experience something similiar before for error: undefined reference with openc v+ ros to some 3rd partry library. It turns out opencv shares couple library with ros. say boost under cv::boost and there is another ros::boost. of course your system gets confused.

I think to solve this. One is to build opencv not with ROS. So when you use it remember not to use using namespace cv; but use every function as cv::boost..... If above not working just remove opencv and compile without ROS and try it again

edit flag offensive delete link more

Comments

I re-install every thing including Linux itself and it seams to be related to the CUDA. booth CUDA 4.2 and 5.0

jcc gravatar image jcc  ( 2013-02-12 12:21:00 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-02-06 07:42:17 -0500

Seen: 209 times

Last updated: Feb 12 '13