Ask Your Question
0

Groovy unmet dependencies Ubuntu 12.04 Precise

asked 2013-01-30 06:10:24 -0500

silgon gravatar image

updated 2013-02-01 09:40:04 -0500

SL Remy gravatar image

I was trying to install groovy in ubuntu 12.04 and I have a problem with dependencies. I tried to install the dependencies separately and I had no success. I already visited the forum and tried this - answers.ros.org/question/52155/how-to-install-groovy-desktop-full-on-1204/ - but it's not working either. Any ideas?

$sudo apt-get install ros-groovy-desktop-full
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ros-groovy-desktop-full : Depends: ros-groovy-navigation-tutorials (= 0.1.1-s1359175367~precise) but it is not going to be installed
                           Depends: ros-groovy-slam-gmapping (= 1.2.7-s1359174918~precise) but it is not going to be installed
                           Depends: ros-groovy-vision-opencv (= 1.10.3-0precise-20130125-2028-+0000) but it is not going to be installed
                           Depends: ros-groovy-perception-pcl (= 1.0.26-0precise-20130126-0228-+0000) but it is not going to be installed
                           Depends: ros-groovy-rqt-common-plugins (= 0.2.10-0precise-20130126-0231-+0000) but it is not going to be installed
                           Depends: ros-groovy-image-pipeline (= 1.10.3-0precise-20130126-0257-+0000) but it is not going to be installed
                           Depends: ros-groovy-stage (= 1.6.7-s1359157880~precise) but it is not going to be installed
                           Depends: ros-groovy-rqt-robot-plugins (= 0.2.8-0precise-20130126-0246-+0000) but it is not going to be installed
                           Depends: ros-groovy-image-transport-plugins (= 1.8.17-0precise-20130126-0212-+0000) but it is not going to be installed
                           Depends: ros-groovy-visualization-tutorials (= 0.7.3-s1359166718~precise) but it is not going to be installed
                           Depends: ros-groovy-laser-pipeline (= 1.5.5-s1359172667~precise) but it is not going to be installed
                           Depends: ros-groovy-simulator-gazebo (= 1.7.9-s1359168833~precise) but it is not going to be installed
                           Depends: ros-groovy-rviz (= 1.9.20-0precise-20130126-0133-+0000) but it is not going to be installed
                           Depends: ros-groovy-navigation (= 1.10.1-s1359173385~precise) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

multiverse reps are allowed and the ros-latest.list's value is correct, with the precise repositories. So yes, I followed the steps of the installation, but it's not working

edit retag flag offensive close merge delete

Comments

multiverse reps are allowed and the ros-latest.list's value is "deb http://packages.ros.org/ros/ubuntu precise main". So yes, I followed the steps of the installation, but it's not working

silgon gravatar imagesilgon ( 2013-02-01 06:22:48 -0500 )edit

Didn't see those sentences at the end (hope the reformatting would make them clearer to others). What happens when you sudo apt-get install ros-groovy-ros-base? If you're up for it, there's also http://www.howtoforge.com/checking-package-dependencies-with-apt-rdepends-on-debian-ubuntu

SL Remy gravatar imageSL Remy ( 2013-02-01 09:52:16 -0500 )edit

sorry for the delay, it install that package an dependencies but when I tried sudo apt-get install ros-groovy-desktop-full it continues with the same error message.

silgon gravatar imagesilgon ( 2013-02-15 05:15:17 -0500 )edit

tried "sudo apt-get update --fix-missing" , not working either

silgon gravatar imagesilgon ( 2013-02-18 10:47:10 -0500 )edit

when I do the command with aptitude install the error is libfontconfig1-dev : Depends: libfontconfig1 (= 2.8.0-3ubuntu9.1) but 2.10.1-0ubuntu3 is to be installed

silgon gravatar imagesilgon ( 2013-02-18 11:21:27 -0500 )edit
1

I had this when I accidentally had the 12.10 repo in ros-latest.list when I should have had the 12.04 "precise" source. It went away after I edited ros-latest.list to ensure "precise", then sudo apt-get clean && sudo apt-get update ; sudo apt-get install ros-groovy-desktop-full.

rgm gravatar imagergm ( 2013-04-23 15:30:05 -0500 )edit

has anyone found a solution to this issue?

ferre gravatar imageferre ( 2013-04-29 18:51:06 -0500 )edit

Yes. If the solution didn't work for you, post a new question so you can get help.

SL Remy gravatar imageSL Remy ( 2013-04-30 03:56:42 -0500 )edit

3 Answers

Sort by » oldest newest most voted
4

answered 2013-03-06 21:01:59 -0500

silgon gravatar image

updated 2013-09-20 09:05:09 -0500

Finally I used sudo aptitude to install it. Aptitude offers you a solution, you answer not, and after that it will offer you to downgrade a package, you select that option and voilà! At least that worked for me.

edit flag offensive delete link more

Comments

This solution worked for me as well ! Thanks :)

Lucile gravatar imageLucile ( 2013-06-11 22:37:22 -0500 )edit

This initially worked for me but I stumpled upon unmet dependencies later on. I am now using the fix described by rgm.

wignode gravatar imagewignode ( 2013-07-28 05:45:16 -0500 )edit
0

answered 2014-02-20 00:23:50 -0500

biswa gravatar image

Thanks , it worked for me sudo aptitute install [package]

Biswajit

edit flag offensive delete link more
0

answered 2013-02-06 15:53:33 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I used --fix-missing to try to track down the unmet dependency. Eventually it was evident that libpoco-dev was the problem.

In my computer, there was another program who had a software source that was forcing different versions for these dependencies.

Upon removing this software source I was able to install all of ROS.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-01-30 06:10:24 -0500

Seen: 2,226 times

Last updated: Feb 20 '14