Ask Your Question
1

rviz in fuerte and ubuntu 12.04 with ATI graphics card is problematic

asked 2012-05-24 03:27:36 -0500

mkillpack gravatar image

I have a new install of fuerte on ubuntu 12.04 with an ATI graphics card. I know that nvidia is the preferred graphics card for using rviz, however in the past (with ubuntu 10.04 and ros-electric), other than being slow I haven't had any problems. Now rviz is practically unusable. It runs fine when it is not rendering any shapes. However, as soon as I add 100-200 shapes, it slows to a crawl and only refreshes every 2-3 seconds (including the ros-time display in rviz).

Is there anything I can disable or compile from source, etc. that might make rviz usable again as a visualization tool for debugging? I tried running ubuntu 2D to see if it would help and even installed gnome 3 in case the unity version of ubuntu was causing problems. None of that helped. I'd be happy running ros-electric on ubuntu 12.04 but it appears that isn't supported.

Any advice would be much appreciated.

edit retag flag offensive close merge delete

Comments

It would probably be useful to add what kind of card you're using. Also, what types of frame rates do you get with glxgears?

SL Remy gravatar imageSL Remy ( 2012-09-04 08:56:34 -0500 )edit

this was for a radeon hd 3XXX series.

mkillpack gravatar imagemkillpack ( 2013-01-28 13:25:43 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2012-09-04 08:55:48 -0500

SL Remy gravatar image

For what it's worth, on a virtual machine running precise, I've seen a modest improvement (5x faster with glxgears) when I went used gazebo classic instead of the default.

edit flag offensive delete link more

Comments

that may be useful in general, but I was using ODE directly with rviz when I saw this problem. It seemed to be a problem with rendering large numbers of markers in a markerarray

mkillpack gravatar imagemkillpack ( 2012-12-13 05:50:37 -0500 )edit

Ok. 7 mths is a long time to be stuck with an unusable debugging process.. but now that groovy is here I'm sure that things are going to change again. I'd suggest trying the new code.. and if the problem is still there, sharing files/information to help someone else re-create what you're observing.

SL Remy gravatar imageSL Remy ( 2012-12-13 06:23:34 -0500 )edit

and also, to be clear, ubuntu classic was installed with sudo apt-get install gnome-session-fallback

SL Remy gravatar imageSL Remy ( 2012-12-13 06:24:07 -0500 )edit

I recently had to reinstall some stuff and had the same problem again. Getting rid of the proprietary ATI drivers and using the open source ones actually resolved the problem. Maybe that can help someone else as well.

mkillpack gravatar imagemkillpack ( 2013-01-28 13:24:39 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2012-05-24 03:27:36 -0500

Seen: 874 times

Last updated: Sep 04 '12