Ask Your Question
0

rviz flick

asked 2011-04-21 02:05:02 -0600

Does anybody have this problem with ATI hardware and ubuntu 10.10? If I active "visual-effects" on ubuntu the main window of RVIZ starts flickering

http://www.youtube.com/watch?v=BDc5PX...

thanks Augusto

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2011-04-23 02:20:59 -0600

partial solution (from the mailing list):

I tried with glxgears (and fgl_glxgears) and I saw the same flickering effect, so I searched with google for the enviroment variable you told me and I found something interesting.

<glxinfo |="" grep="" rendering=""> reports direct rendering: No (LIBGL_ALWAYS_INDIRECT set) to correct this behavior I typed <unset libgl_always_indirect=""> and the flickering on glxgears disapperas, and also on Rviz.

I noticed this: if I launch the terminal with Ctrl+Alt+T I get <<direct rendering:="" no="" (libgl_always_indirect="" set)&gt;&gt;="" but="" if="" i="" launch="" konsole="" instead="" with="" alt+f2="" i="" get="" &lt;<direct="" rendering:="" yes="">> I don't understand exactly what is happening, but the only other way to solve the problem is disabling compiz like Nathaniel wrote. I think that there is some method to launch a window/console without using compiz even the system is using it, but I don't know how.

For now I put <unset libgl_always_indirect=""> at the end of .bashrc and seems to work fine.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-04-21 02:05:02 -0600

Seen: 214 times

Last updated: Apr 23 '11