Ask Your Question
0

How to get opencv on electric precise (ubuntu 12.04)?

asked 2012-04-11 08:53:49 -0500

ssafarik gravatar image

Does anyone know how I can get vision_opencv installed on electric/precise? Thanks.

I'm running Ubuntu Precise (12.04) and ROS electric, and cannot seem to install opencv2.3 aka vision_opencv. "rosdep install vision_opencv" fails due to there not being a "precise" build of it available, e.g. "No installers found for rosdep [opencv2.3], OS version [precise]..."

I'm also unable to build OpenCV-2.3.1 separately; a bunch of warnings, then: make[2]: * [modules/highgui/CMakeFiles/opencv_highgui.dir/src/cap_ffmpeg.o] Error 1 make[1]: [modules/highgui/CMakeFiles/opencv_highgui.dir/all] Error 2 make: ** [all] Error 2

Steve.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
3

answered 2012-04-11 11:42:31 -0500

kwc gravatar image

updated 2012-04-11 11:42:47 -0500

ROS Electric does not support Ubuntu Precise. See [1]. You will have to wait until ROS Fuerte support for Precise is added (in progress) if you wish to have a binary install and the relevant compatibility fixes.

Otherwise, you will to continue down the manual source build that you've been doing and deal with the compatibility issues that crop up.

edit flag offensive delete link more
4

answered 2012-04-11 11:41:20 -0500

ssafarik gravatar image

Looks like the answer is to edit the vision_opencv/rosdep.yaml file to add an entry for precise, thus getting it to use the package libopencv-dev that you can install via Synaptic, etc. For example, here's part of my vision_opencv/rosdep.yaml:

opencv2.3:
  ubuntu:
    lucid:
      apt:
        packages: [libopencv2.3-dev=2.3.1+svn6514+branch23-12~lucid]
    maverick:
      apt:
        packages: [libopencv2.3-dev=2.3.1+svn6514+branch23-12~maverick]
    natty:
      apt:
        packages: [libopencv2.3-dev=2.3.1+svn6514+branch23-12~natty]
    oneiric:
      apt:
        packages: [libopencv2.3-dev=2.3.1+svn6514+branch23-12~oneiric]
    precise: 
      apt:
        packages: [libopencv-dev]
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-04-11 08:53:49 -0500

Seen: 1,480 times

Last updated: Apr 11 '12