Ask Your Question
0

gazebo on groovy ERROR

asked 2013-01-28 11:02:09 -0500

monidiaz gravatar image

updated 2013-01-29 02:49:18 -0500

I'm trying to install gazebo for groovy on fuerte.

first run : rosws set --svn simulator_gazebo https://code.ros.org/svn/ros-pkg/stacks/simulator_gazebo/tags/groovy/

  1. rosws update
  2. rosmake simulator_gazebo

An i got this error:

-- BUILD ERRORS: These must be resolved before compiling.
  --    Missing: Ogre3d version >=1.7.1(http://www.orge3d.org)
  -- END BUILD ERRORS

and i was searching how get it , but doesn't work .

pd: i was trying others version of gazebo 'cause i need someone the collision works.

EDIT:

> Running rosdep install
> simulator_gazebo gazebo_tests: Cannot
> locate rosdep definition for
> [protobuf-dev] gazebo_tools: Cannot
> locate rosdep definition for
> [protobuf-dev] gazebo: Cannot locate
> rosdep definition for [protobuf-dev]
> gazebo_plugins: Cannot locate rosdep
> definition for [protobuf-dev]
> gazebo_worlds: Cannot locate rosdep
> definition for [protobuf-dev]
edit retag flag offensive close merge delete

Comments

Did you intend to check out the Groovy version of gazebo to build on Fuerte?

joq gravatar image joq  ( 2013-01-28 14:02:59 -0500 )edit

yes, that is what i'm doing

monidiaz gravatar image monidiaz  ( 2013-01-28 14:45:07 -0500 )edit
1

What version of ogre do you have? Did you run rosdep install simulator_gazebo?

joq gravatar image joq  ( 2013-01-28 15:18:16 -0500 )edit

how can i know the version of ogre? i suppose i have that fuerte version get. And when i run rosdep install simulator_gazebo i have some errors, see EDIT Question

monidiaz gravatar image monidiaz  ( 2013-01-29 02:48:08 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2013-01-29 03:42:29 -0500

joq gravatar image

You did not mention what OS you are running.

On Ubuntu Precise, I have OGRE 1.7.4-3, which seems to work fine:

$ dpkg -s libogre-dev
Package: libogre-dev
Status: install ok installed
Priority: optional
Section: libdevel
Installed-Size: 6044
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Architecture: amd64
Source: ogre
Version: 1.7.4-3
Depends: libogre-1.7.4 (= 1.7.4-3), libboost-date-time-dev, libboost-thread-dev, libfreeimage-dev, libfreetype6-dev, libzzip-dev, libxaw7-dev
Suggests: ogre-doc
Description: 3D Object-Oriented Graphics Rendering Engine (development files)
 OGRE (Object-Oriented Graphics Rendering Engine) is a scene-oriented, flexible
 3D engine written in C++ designed to make it easier and more intuitive for
 developers to produce applications utilising hardware-accelerated 3D
 graphics. The class library abstracts all the details of using the underlying
 system libraries like Direct3D and OpenGL and provides an interface based on
 world objects and other intuitive classes.
 .
 This package contains the headers needed to develop with OGRE.
Original-Maintainer: Debian Games Team <pkg-games-devel@lists.alioth.debian.org>
Homepage: http://ogre3d.org/

Perhaps you just need to install that package.

edit flag offensive delete link more

Comments

thnks, i have to install ogre (sudo apt-get install libogre-dev) and make again "rosmake" and that's works thnks. the sad thing is that for my computer is so heavy. i'll go to try electric version.

monidiaz gravatar image monidiaz  ( 2013-01-29 09:24:30 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-01-28 11:02:09 -0500

Seen: 475 times

Last updated: Jan 29 '13