Ask Your Question
1

roscd only finding rosbuild packages

asked 2013-01-15 13:45:22 -0500

Dave Coleman gravatar image

updated 2013-01-15 14:00:50 -0500

I'm on Groovy/Ubuntu 12.04. Yesterday I installed the stand alone install of Gazebo because they no longer support the older version of Gazebo that comes with ROS. It also required that I install Fuerte debians because it still has some of those dependencies. I've heard that different version of ROS can be installed along side each other so long as you only source one. But the problem is that now roscd only can find rosbuild packages - ones with manifest.xml files in them. I confirmed this with ROS, MoveIt and my own packages. Am I correct in assuming that this is because Fuerte is also installed on my computer?

According to Gazebo's website:

ROS Users: Only install Gazebo from here. Never use the instruction on the ros.org website.

So that is what I did.

Update: It appears roscd stops working correctly after I run

rosrun urdf_parser check_urdf robot.urdf
[rospack] Error: stack/package urdf_parser not found
[rosrun] Couldn't find executable named check_urdf below

Is this at all possible?

edit retag flag offensive close merge delete

Comments

To help find and fix this, can you report the exact steps you did in a ticket at https://github.com/ros/ros_comm/issues. Explain where you source which setup.sh (.bashrc?), and then what commands you run in the terminal until roscd misbehaves.

KruseT gravatar imageKruseT ( 2013-01-15 22:31:37 -0500 )edit

The solution I found was to just not sure the Gazebo 1.3 debian, uninstalling along with it all of Gazebo's Fuerte dependencies. When I do that everything works - with the same setup.sh stuff as instructed in the catkin workspace instructions. I'm going to give Gazebo some time to adjust to Groovy.

Dave Coleman gravatar imageDave Coleman ( 2013-01-22 14:18:26 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2013-01-15 14:10:13 -0500

Dave Coleman gravatar image

Ok, I think I've figured it out:

  1. urdf_parser is depreciated in Groovy, but this is not documented on its wiki page

  2. The latest version of Gazebo (1.3) still requires ros-fuerte-urdfdom, so I had this on my system as well

  3. Somehow when I do rosrun urdf_parser check_urdf robot.urdf it confused my computer into no longer understanding catkin packages, essentially throwing it into "fuerte" mode

edit flag offensive delete link more

Comments

The wiki is also free for you to edit, to help other users following in your footsteps. rosrun cannot change the environment, at worst it could have some impact on the rospack cache, which would be a serious bug to fix.

KruseT gravatar imageKruseT ( 2013-01-15 22:26:38 -0500 )edit

I tried to edit the wiki but there is no section for Groovy (no button at the top)

Dave Coleman gravatar imageDave Coleman ( 2013-01-22 14:20:25 -0500 )edit

the buttons are generated by a special macro that you can insert yourself. Just llok at the page source for a page with the buttons.

KruseT gravatar imageKruseT ( 2013-01-23 00:34:24 -0500 )edit

I added a note about the change, but I don't know enough about the new urdfdom to write the documentation. They seem to have changed packages entirely.

Dave Coleman gravatar imageDave Coleman ( 2013-01-25 09:19:16 -0500 )edit
1

answered 2013-01-15 13:50:58 -0500

Dirk Thomas gravatar image

roscd does support catkin packages. On a clean installation (with no old versions of tools installed via PIP) after sourcing /opt/ros/groovy/setup.bash the command "roscd roscpp" brings you to /opt/ros/groovy/share/roscpp.

So double check that you have the latest version from all the tools installed and no old PIP packages.

edit flag offensive delete link more

Comments

I believe I do have the latest everything

Dave Coleman gravatar imageDave Coleman ( 2013-01-15 14:02:51 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-01-15 13:45:22 -0500

Seen: 664 times

Last updated: Jan 15 '13