After adding repository to overlay, package still not in package path

asked 2017-02-20 15:30:45 -0600

I'm currently getting into ROS and rosbuild and as start I'm working trough this tutorial, but I'm stuck at:

Adding repositories to the overlay

I did the following things before that point:

rosws init . /opt/ros/kinetic
source setup.zsh
mkdir sandbox
myros rosws set sandbox

Now the basic Overlay is set up, i can access the package roscpp with roscd roscpp and after that I am able to return to my new overlay with roscd - so i add a repository

rosws set turtlebot --git -u https://github.com/turtlebot/turtlebot
rosws update

My .rosinstall file looks like this at this moment:

setup-file: {local-name: /opt/ros/kinetic/setup.sh}
other: {local-name: sandbox}
git: {local-name: turtlebot, uri: 'https://github.com/turtlebot/turtlebot'}

After that the Tutorial says:

After re-sourcing setup.bash the new overlayed stack turtlebot should be in your package path, i.e. roscd turtlebot should switch to the directory ~/fuerte_workspace/turtlebot.

If i want to use roscd turtlebot I'm getting:

roscd: No such package 'turtlebot'

Because the tutorial says

After re-sourcing setup.bash should be in your package path...

I tried resourcing with source source.zsh but thats now working either. What am i doing wrong?

edit retag flag offensive close merge delete

Comments

Could you first tell us why you want to use rosbuild instead of Catkin?

gvdhoorn gravatar imagegvdhoorn ( 2017-02-21 01:54:26 -0600 )edit