ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Install of Groovy on Ubuntu 12.10 Problem

asked 2013-01-09 05:36:09 -0600

Dereck gravatar image

updated 2013-01-13 06:56:33 -0600

Kevin gravatar image

I upgraded from U12.04 where I was using ROS-F to U12.10 and then attempted to install ROS-G.

It seems that there is a conflict between libyaml-cpp-dev and yaml-cpp which needs to have a 'conflicts' added to the .deb package. (Error Below)

Unpacking libyaml-cpp-dev (from .../libyaml-cpp-dev_0.3.0-1_amd64.deb) ... dpkg: error processing /var/cache/apt/archives/libyaml-cpp-dev_0.3.0-1_amd64.deb (--unpack): trying to overwrite '/usr/include/yaml-cpp/aliasmanager.h', which is also in package yaml-cpp 0.2.7-5precise-20120502-0513-+0000 No apport report written because MaxReports is reached already

dpkg-deb: error: subprocess paste was killed by signal (Broken pipe) Errors were encountered while processing: /var/cache/apt/archives/libyaml-cpp-dev_0.3.0-1_amd64.deb E: Sub-process /usr/bin/dpkg returned an error code (1)

This error happens now whenever I try to use apt-get and I'm unable to install or remove packages from my system. Help Please?

edit retag flag offensive close merge delete



Also, make sure your /etc/apt/sources.list.d/ros-latest.list was updated correctly for the new Ubuntu version.

joq gravatar image joq  ( 2013-01-09 08:25:56 -0600 )edit

I updated many times without success. Also, the sources appear correct.

Dereck gravatar image Dereck  ( 2013-01-09 09:01:44 -0600 )edit

3 Answers

Sort by ยป oldest newest most voted

answered 2013-02-10 05:55:48 -0600

philotuxo gravatar image

updated 2013-02-10 05:57:53 -0600

I had the same conflict. The conflict was actually between yaml-cpp and libyaml-cpp-dev.

sudo apt-get remove ^ros*
sudo apt-get remove --purge yaml-cpp
sudo apt-get install ros-groovy-desktop-full

resolved my issue.

edit flag offensive delete link more

answered 2013-01-09 08:23:58 -0600

joq gravatar image

I agree that this looks like a package conflict. First re-run apt-get update, then you can try to remove yaml-cpp and all its dependencies, and retry the install.

edit flag offensive delete link more

answered 2013-01-09 09:00:09 -0600

Dereck gravatar image


sudo apt-get remove ^ros*

Now to attempt a re-install. :)

edit flag offensive delete link more


What happened when you tried just removing yaml-cpp and its dependencies?

joq gravatar image joq  ( 2013-01-09 09:25:22 -0600 )edit

It gave me a bunch more errors about other packages which depended on it and such. FWIW I was able to sudo apt-get install ros-groovy-desktop-full without any problems. Perhaps it worked this time because the above glob also removed all of my ROS-F packages as well.

Dereck gravatar image Dereck  ( 2013-01-09 10:24:13 -0600 )edit

Fuerte is not supported on quantal. If you have fuerte packages after upgrading, they will have conflicting dependencies which dpkg cannot resolve. Removing ros-fuerte-* is the right solution.

tfoote gravatar image tfoote  ( 2013-01-14 09:43:30 -0600 )edit

Question Tools


Asked: 2013-01-09 05:36:09 -0600

Seen: 698 times

Last updated: Feb 10 '13