Ask Your Question
0

groovy OSX install fails building opencv2 because LONG_BIT definition appears wrong for platform

asked 2013-01-02 18:22:46 -0600

Nick J Chalko gravatar image

updated 2014-01-28 17:14:42 -0600

ngrennan gravatar image

Following the instructions at http://www.ros.org/wiki/groovy/Installation/Source#Building_the_catkin_Workspace

I run

./src/catkin/bin/catkin_make_isolated --install

But it fails. greping the logs yeilds

Building CXX object modules/python/CMakeFiles/opencv_python.dir/src2/cv2.cpp.o
modules/core/doc/old_basic_structures In file included from /Users/nchalko/ros_catkin_ws/src/opencv2/modules/python/src2/cv2.cpp:1:
In file included from /Library/Frameworks/Python.framework/Headers/Python.h:55:
/Library/Frameworks/Python.framework/Headers/pyport.h:616:2: error: "LONG_BIT definition appears wrong for platform (bad gcc/glibc config?)."
#error "LONG_BIT definition appears wrong for platform (bad gcc/glibc config?)."
 ^

I played with building opencv by hand but never got only got it to work by not building the python part.

Note:

brew install opencv

works fine

I am running OS X 10.8.2 (12C60) And using xcode Version 4.5.2 (4G2008a)

I am stuck. my pthyon + cmake foo is too weak to know were to start.

So how can I get groovy to install opencv2 on my mac.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-01-03 14:06:48 -0600

Kevin gravatar image

Try using the OSX install instructions ... that might help. Also I don't have this: /Library/Frameworks/Python.framework/Headers/pyport.h ... try uninstalling this, since it seems to be causing problems and this isn't where homebrew installs python modules too.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-01-02 18:22:46 -0600

Seen: 751 times

Last updated: Jan 03 '13