Ask Your Question
2

Error with rosinstall: rosws cannot find lib

asked 2012-12-30 04:02:13 -0600

leoa gravatar image

updated 2012-12-30 04:58:35 -0600

KruseT gravatar image

Hi, I migrated from ros diamondback to ros fuerte. I wanted to create a workspace with rosws as stated on the wiki, but I get this error:

ERROR Cannot find rosinstall libraries, check your installation. One frequent cause is that rosinstall 0.5 is still installed in /usr/local/lib. No module named rosws_cli

I just dont know how to solve that.

edit retag flag offensive close merge delete

Comments

1

Hi @KruseT, I dont know why but I cannot comment on your answer. I followed your instructions but the problem persists. If I understand right, rosws is looking for: /usr/share/pyshared/rosinstall/rosws_cli.py. Both packages rosinstall and vcstools are up to date. I also removed what you told me.

leoa gravatar imageleoa ( 2012-12-30 07:43:50 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
4

answered 2012-12-30 04:53:39 -0600

KruseT gravatar image

updated 2013-07-31 02:19:03 -0600

As the error states, a frequent cause is that you have an old version of rosinstall in /usr/local/lib, as well as a newer version somewhere.

Another source is when you have updated rosinstall, but not vcstools.

So first try to update rosinstall and vcstools:

$ sudo apt-get update python-rosinstall python-vcstools

If that works, all is well. Else on Ubuntu, you can do

$ sudo rm -rf /usr/local/lib/python2.7/dist-packages/rosinstall*
$ sudo rm -rf /usr/local/lib/python2.7/dist-packages/vcstools*
$ sudo rm -rf /usr/local/bin/rosws /usr/local/bin/roslocate /usr/local/bin/rosinstall /usr/local/bin/rosco

This might be "python2.6" instead of "python2.7" on some systems.

If you never had them installed via apt-get, do so:

$ sudo apt-get install python-rosinstall python-vcstools

EDIT: Please comment on my question what caused this for you if you find out, it can help us improve the support.

edit flag offensive delete link more
1

answered 2013-06-28 05:04:26 -0600

sd1074 gravatar image

I am not sure what exactly went wrong in my case, but I had the same issue, and KruseT's advice didn't really work for me.

To resolve the problem (maybe not the cleanest solution), I created a couple of symlinks:

sudo ln -s /usr/share/pyshared/rosinstall /usr/lib/python2.7/dist-packages/rosinstall
sudo ln -s /usr/share/pyshared/vcstools /usr/lib/python2.7/dist-packages/vcstools

This worked for me.

edit flag offensive delete link more

Comments

I changed my response to also delete the old executables. Not sure whether that would have helped you.

KruseT gravatar imageKruseT ( 2013-07-31 02:20:52 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-12-30 04:02:13 -0600

Seen: 1,373 times

Last updated: Jul 31 '13