Ask Your Question
1

Install Err no package conf file message_generation

asked 2012-12-18 23:25:20 -0500

J.M.T. gravatar image

Hello,

I am trying to install groovy on OSx 10.8.2, following this guide

hxxp://www.ros.org/wiki/groovy/Installation/OSX/Homebrew/Source

when i configure the build this happens

-- +++ processing catkin package: 'std_msgs' -- ==> add_subdirectory(std_msgs) CMake Error at build/devel/share/catkin/cmake/catkinConfig.cmake:71 (find_package): Could not find a package configuration file provided by "message_generation" with any of the following names:

message_generationConfig.cmake
message_generation-config.cmake

Add the installation prefix of "message_generation" to CMAKE_PREFIX_PATH or set "message_generation_DIR" to a directory containing one of the above files. If "message_generation" provides a separate development package or SDK, be sure it has been installed. Call Stack (most recent call first): std_msgs/CMakeLists.txt:4 (find_package)

-- Configuring incomplete, errors occurred!

Can someone please help?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
4

answered 2012-12-19 10:57:56 -0500

yoos gravatar image

updated 2013-01-02 02:52:42 -0500

I had the same problem while installing groovy on Arch Linux.

I fixed it by cloning into the repository (and message_runtime) in groovy_underlay thusly:

cd ~/groovy_underlay
git clone https://github.com/ros/message_generation.git
git clone https://github.com/ros/message_runtime.git
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-12-18 23:25:20 -0500

Seen: 1,102 times

Last updated: Jan 02 '13