ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

glc installation in ubuntu 12.04

asked 2012-12-17 22:11:52 -0500

KARTHIK MURUGAN gravatar image

I want to record the figure(point cloud) displayed in rviz as a jpeg image.I followed the instructions in /wiki/RecordingOpenGLAppsWithGLC (RecordingOpenGLAppsWithGLC) but unable to install.


while following the steps as shown in screenshot i get an error:-


any thoughts ??

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted

answered 2012-12-17 22:58:05 -0500

Lorenz gravatar image

updated 2012-12-18 02:27:42 -0500

Follow the install instructions for installing from a PPA. You shouldn't have to compile anything.

For just taking screenshots, every screenshot application should work. I personally use ksnapshot. For recording videos, I normally use xvidcap which can be installed in Ubuntu using apt-get and it should just work.

edit flag offensive delete link more


Thank u Lorenz, I followed the instuctions given there sudo add-apt-repository ppa:arand/ppa ; sudo apt-get update ; sudo apt-get install glc; after that when i do(as per bash i get error :- bash: No such file or directory

KARTHIK MURUGAN gravatar image KARTHIK MURUGAN  ( 2012-12-18 16:31:29 -0500 )edit

You need to be in the directory where that file is installed to run it.

tfoote gravatar image tfoote  ( 2013-01-14 12:06:02 -0500 )edit

answered 2012-12-18 02:41:39 -0500

alfa_80 gravatar image

I had a similar problem before on 12.04, but it's solved by installing these:

sudo apt-get install libglc0

sudo apt-get install libglc-dev #(optional)

Give it a try and all the best :-)

edit flag offensive delete link more


@karthik: I apologize from my mistake, it's actually not libglc that I had the problem previously but libgsl, my bad..

alfa_80 gravatar image alfa_80  ( 2012-12-18 23:38:17 -0500 )edit

answered 2012-12-17 23:22:53 -0500

Did you check whether the path /usr/lib32/ exists?

The command

sudo ln -s /usr/lib32/ /usr/lib32/

just created a symbolic link named /usr/lib32/ to /usr/lib32/

Here's a question same as yours.

edit flag offensive delete link more


Thank u Ricky/usr/lib32 does not exist. But instead in usr directory lib64 exists. I tried changing the command with lib64, and now i dont get any error but in lib64 folder, when i have a look at the files(right click->properties) it says broken link. Is that ok? or should i do something else?

KARTHIK MURUGAN gravatar image KARTHIK MURUGAN  ( 2012-12-18 16:27:20 -0500 )edit

Really? There's in lib64? If you follow the instructions above, you should have lib32 directory. Maybe you should execute the command that installs libGL again and check if there's lib32.

Po-Jen Lai gravatar image Po-Jen Lai  ( 2012-12-23 20:02:58 -0500 )edit

Question Tools


Asked: 2012-12-17 22:11:52 -0500

Seen: 673 times

Last updated: Dec 18 '12