Kinect for windows using ros fuerte [closed]

asked 2012-12-12 03:44:51 -0600

Lean2 gravatar image

updated 2016-10-24 08:34:15 -0600

ngrennan gravatar image

Im using ububtu 12.04 and ROS Fuerte, Im trying to use the Kinect For windows with the Openni_kinect driver, I more or less have followed the instructions in:

http://answers.ros.org/question/12876/kinect-for-windows/

I changed the rules in, 55-primesense-usb.rules and changed XnDeviceSensorIO.cpp

changed the following lines

#define XN_SENSOR_MSK_PRODUCT_ID 0x02BF and the following lines xnLogVerbose(XN_MASK_DEVICE_IO, "Setting USB interface to %d...", 1); nRetVal = xnUSBSetInterface(m_pSensorHandle->USBDevice, 0, 1);

Now when I use roslaunch openni_launch openni.launch i get the following error message

Does anyone knows how I can solve this problem? or if there will be anytime soon a version of openni_kinect suporting K4w.

the error message that I get is the following

"**[ INFO] [1358951643.387157389]: Number devices connected: 1 Im really having big trouble to set the alternative isochronous endpoint. What shoul I do to enable the endpoint in order to the depth generator do not fail?

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2015-10-14 16:12:17.423417

Comments

I don't see the error message...

jarvisschultz gravatar image jarvisschultz  ( 2012-12-12 10:08:22 -0600 )edit

Thanks for interest in the question, I add the error message

Lean2 gravatar image Lean2  ( 2013-01-23 02:45:48 -0600 )edit

the errors are still not visible

georgebrindeiro gravatar image georgebrindeiro  ( 2013-01-23 03:12:02 -0600 )edit