ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

rosmake openni_camera gives an error

asked 2012-12-04 03:35:29 -0600

Schlangenmensch gravatar image

updated 2012-12-04 03:36:59 -0600


i had to reinstall my system. Before, i made a backup of my ros workspace.

After installing ros, i tried my old launch files and they don't work. I solved some errors already. But, if i try to build openni_camera with "rosmake openni_camera" i get an error:

make[2]: execvp: cfg/OpenNIUnstable.cfg: Permission denied make[2]: * [cfg/cpp/openni_camera/OpenNIUnstableConfig.h] Error 127 make[1]: * [CMakeFiles/ROSBUILD_gencfg_cpp.dir/all] Error 2

Can somebody gives me a hint to solve this problem?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted

answered 2012-12-04 04:45:25 -0600

Schlangenmensch gravatar image

Thanks for the fast answer. But the problem was the follow:

I had an old openni_camera stack as backup in my workspace, because I changed there something. And now ROS tried to compile the older version from my workspace. So, I moved it away from my workspace an I am using the actual openni_camera stack now. And it works fine ;)

edit flag offensive delete link more

answered 2012-12-04 04:08:06 -0600

dornhege gravatar image

updated 2012-12-04 04:09:02 -0600

I guess when restoring your system backup, you did not transfer ownership or permissions correctly.

You'd probably want to do something like:

sudo chown -R mynewuser ros_workspace

and maybe also

sudo chmod -R u+rwX ros_workspace

Also, you should run make clean on each of the packages in the workspace or remove the build/ directories as cmake might have cached directories there.

edit flag offensive delete link more

Question Tools


Asked: 2012-12-04 03:35:29 -0600

Seen: 552 times

Last updated: Dec 04 '12