Ask Your Question
0

can't find a dependency

asked 2012-11-21 21:15:23 -0500

Nachum gravatar image

updated 2012-11-22 21:11:31 -0500

Hi I was building a package from a tutorial link text but when I tried doing rosmake I got an error

Failed to invoke /opt/ros/fuerte/bin/rospack deps-manifests trajectory_control_tutorial
[rospack] Error: package/stack trajectory_control_tutorial depends on non-existent package drc_robot_utils

I was already working with the drc robot and I know I have it on my disk.

what should I write instead? thanks

Nachum

Edit\ Now I tried to run a file that I used before from a package that has that dependency and I am getting this error-

    Traceback (most recent call last):
  File "/home/nachum/joint_control_tutorial/scripts/joint_control12.py", line 3, in <module>
    import roslib; roslib.load_manifest('drc_robot_utils')
  File "/opt/ros/fuerte/lib/python2.7/dist-packages/roslib/launcher.py", line 62, in load_manifest
    sys.path = _generate_python_path(package_name, _rospack) + sys.path
  File "/opt/ros/fuerte/lib/python2.7/dist-packages/roslib/launcher.py", line 93, in _generate_python_path
    m = rospack.get_manifest(pkg)
  File "/usr/local/lib/python2.7/dist-packages/rospkg/rospack.py", line 118, in get_manifest
    return self._load_manifest(name)
  File "/usr/local/lib/python2.7/dist-packages/rospkg/rospack.py", line 157, in _load_manifest
    retval = self._manifests[name] = parse_manifest_file(self.get_path(name), self._manifest_name)
  File "/usr/local/lib/python2.7/dist-packages/rospkg/rospack.py", line 149, in get_path
    raise ResourceNotFound(name, ros_paths=self._ros_paths)
rospkg.common.ResourceNotFound: drc_robot_utils
ROS path [0]=/opt/ros/fuerte/share/ros
ROS path [1]=/home/nachum
ROS path [2]=/home/nachum/ros
ROS path [3]=/home/nachum/ros
ROS path [4]=/opt/ros/fuerte/share
ROS path [5]=/opt/ros/fuerte/stacks

what could of happened?

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
1

answered 2012-11-22 21:13:54 -0500

Both errors mean that the package drc_robot_utils was not found. Make sure that it is on your ROS_PACKAGE_PATH. You can try if it is by running roscd drc_robot_utils; that should bring you to the package directory.

edit flag offensive delete link more

Comments

yes that's what it was. how do I permanently put a path on my ros path? I think I put it by echo "source /opt/ros/fuerte/setup.bash" >> ~/.bashrc . ~/.bashrc

Nachum gravatar image Nachum  ( 2012-11-27 19:20:23 -0500 )edit

Yes, but after that line you should add the path to the packages in your home dir like this: echo 'export ROS_PACKAGE_PATH=/home/nachum/ros/drc_robot_utils:$ROS_PACKAGE_PATH' &gt;&gt; ~/.bashrc. You can also use rosws instead.

Martin Günther gravatar image Martin Günther  ( 2012-11-29 00:36:22 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-11-21 21:15:23 -0500

Seen: 1,326 times

Last updated: Nov 22 '12