Boost x86_64 rxtools make error in OS-X Mountain Lion [closed]

asked 2012-11-16 00:19:20 -0500

tropic gravatar image

updated 2012-11-16 00:59:10 -0500


I am making a clean install of ROS fuerte on OS X mountain lion as per the guide. Everything is working so far until make -j8 and linking to boost. The error I receive is Undefined symbols for architecture x86_64: and this I have solved earlier by adding system to boost in the CMakeLists.txt files where needed.

rosbuild_link_boost(${PROJECT_NAME} thread system)

The error I receive now looks like it is for rxtools, but I cannot figure out where and how to add the same to CMakeLists.txt for this package.

How should the CMakeLists.txt be edited so it links correctly to boost?

See the make error below:

[ 97%] Built target turtlesim_node
[ 98%] Built target rosbag
[ 98%] Built target play
[ 98%] Built target record
Linking CXX shared library ../../lib/librxtools.dylib
Undefined symbols for architecture x86_64:
  "wxRichTextCtrl::ms_classInfo", referenced from:
      rxtools::TextboxDialog::onChar(wxKeyEvent&) in rosout_list_control.cpp.o
  "wxRichTextCtrl::wxRichTextCtrl(wxWindow*, int, wxString const&, wxPoint const&, wxSize const&, long, wxValidator const&, wxString const&)", referenced from:
      rxtools::TextboxDialog::TextboxDialog(wxWindow*, int, wxString const&, wxPoint const&, wxSize const&, long) in rosout_generated.cpp.o
  "wxRichTextBuffer::BeginTextColour(wxColour const&)", referenced from:
      wxRichTextCtrl::BeginTextColour(wxColour const&) in rosout_list_control.cpp.o
  "wxRichTextBuffer::BeginBold()", referenced from:
      wxRichTextCtrl::BeginBold() in rosout_list_control.cpp.o
ld: symbol(s) not found for architecture x86_64
clang: error: linker command failed with exit code 1 (use -v to see invocation)
make[2]: *** [lib/librxtools.dylib] Error 1
make[1]: *** [rx/rxtools/CMakeFiles/rxtools.dir/all] Error 2
make: *** [all] Error 2

Edit: Have tried this solution reinstalling the latest wxPython but this did not help

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2015-10-16 13:19:28.278498