Ask Your Question
1

image_raw and camera_info not synchronized in Wlan

asked 2012-11-12 02:58:05 -0500

DontPanic gravatar image

updated 2012-11-12 15:17:02 -0500

Eric Perko gravatar image

Hi, I am trying to send compressed depthimages over "/camera/depth/image_raw" topic using image_transport on Wlan. But even compressed they seem to be too big for the Wlan. The program subscribing the topic throws the warning "Topics 'camera/depth/image_raw/compressedDepth' and 'camera/depth/camera_info' do not appear to be synchronized. In the last 10s: Image messages received: 142 CameraInfo messages received: 174 Sychronized pairs: 21"

How can I sychronize the messages. Is there a way to apply another time policy in image_topic without using message_filters or would using message_filters be the way to go?

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
2

answered 2012-11-12 06:30:29 -0500

Have you tried to synchronize your messages with ApproximateTime in message filters ? It uses time stamps to synchronize two topics, even if they are slightly unsynchronised.

edit flag offensive delete link more

Comments

It is not, that they are really unsynchronised. The time is synchron, but my wireless is the bottleneck. More camera_info messages than actual image messages pass through. So somehow I have to use the ones where two messages are available and ignore the rest. Can message_filters do this?

DontPanic gravatar image DontPanic  ( 2012-11-12 23:15:51 -0500 )edit

Yes, this is precisely what the time synchronizer does.

dornhege gravatar image dornhege  ( 2012-11-12 23:38:44 -0500 )edit
1

answered 2012-11-12 06:52:10 -0500

dornhege gravatar image

Are you sending the images yourself? Then whenever you send a camera image, you should send a camera info with exactly the same timestamp.

Given that is the case, I suspect the synchronization error comes from missing data over wireless. You might be able to check that by looking at the timestamps you received in camera_info and images.

edit flag offensive delete link more

Comments

I am using openni and the Microsoft Kinect so the timestamp is the same. But the compressed depth images still seem to be too big for my wireless.

DontPanic gravatar image DontPanic  ( 2012-11-12 23:21:10 -0500 )edit
0

answered 2020-01-19 20:13:55 -0500

Rufus gravatar image

A quick fix seems to be to throttle the image publishing. For my case, it was the CPU that could not keep up with the large number of image frames coming in (as indicated by the 100% CPU usage). I throttled down the FPS and the error went away once my CPU usage was less than 100%

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2012-11-12 02:58:05 -0500

Seen: 3,757 times

Last updated: Jan 19 '20