Ask Your Question
0

laser_scan_matcher crash

asked 2012-11-07 06:22:59 -0500

randaz gravatar image

updated 2012-11-08 00:22:22 -0500

Lorenz gravatar image

Hi, When I use laser_scan_matcher everything works well for about 5-10 minutes, then the module crashes with the following output:

[laser_scan_matcher_node-1] process has died [pid 6944, exit code -11, cmd /opt/ros/fuerte/stacks/scan_tools/laser_scan_matcher/bin/laser_scan_matcher_node scan:=/my_robot_bridge/laser_out odom:=/my_robot_bridge/odometry_out __name:=laser_scan_matcher_node __log:=/home/user/.ros/log/57fa5eac-28cd-11e2-b8c6-00221522c9d6/laser_scan_matcher_node-1.log].
log file: /home/user/.ros/log/57fa5eac-28cd-11e2-b8c6-00221522c9d6/laser_scan_matcher_node-1*.log

I searched for the log file in the suggested path, but I was not able to find it. Do you have any other suggestion to understand what's going on?

Additional info: I don't know if it is related, but when I start the laser_scan_matcher I get the following warnings (but the module works correctly)

core service [/rosout] found
Exception AttributeError: AttributeError("'_DummyThread' object has no attribute '_Thread__block'",) in <module 'threading' from '/usr/lib/python2.7/threading.pyc'> ignored
process[laser_scan_matcher_node-1]: started with pid [6944]
[ INFO] [1352310705.912643992]: Starting LaserScanMatcher
Exception AttributeError: AttributeError("'_DummyThread' object has no attribute '_Thread__block'",) in <module 'threading' from '/usr/lib/python2.7/threading.pyc'> ignored

Additional info about my system: I am using Ubuntu 12.04 with ROS distro fuerte. For the installation of laser_scan_matcher I followed the instructions reported here: http://www.ros.org/wiki/scan_tools?distro=fuerte. Currently I'm using the following parameters:

<node pkg="laser_scan_matcher" type="laser_scan_matcher_node" 
name="laser_scan_matcher_node" output="screen" args="scan:=/my_robot_bridge/laser_out">
<param name="fixed_frame" value = "odom"/>
<param name="base_frame" value="base_link"/>
<param name="use_alpha_beta" value="true"/>
<param name="publish_tf" value="true"/>
<param name="max_iterations" value="10"/>
<param name="use_imu" value="false"/>
<param name="use_odom" value="false"/>
</node>
edit retag flag offensive close merge delete

Comments

Could you give a little more information: ros version, os version, etc. Also, the which version of the scan matcher are you using?

Ivan Dryanovski gravatar image Ivan Dryanovski  ( 2012-11-07 07:54:08 -0500 )edit

Is the problem reproducible? Have you tried running laser_scan_matcher_node in a debugger (such as gdb) to see exactly where it dies?

Ivan Dryanovski gravatar image Ivan Dryanovski  ( 2012-11-07 12:08:29 -0500 )edit
1

I got the following output:

Program received signal SIGSEGV, Segmentation fault.
0xb7a2ee6d in alloc_int_array (n=1080, def=-1)
at /opt/ros/fuerte/stacks/scan_tools/csm/build/csm-git/sm/csm/laser_data.c:29
29                      v[i] = def;

maybe a memory leak?

randaz gravatar image randaz  ( 2012-11-08 02:56:23 -0500 )edit
1

confirmed memory leak (I see the consumed ram constantly increasing, >1Gb in few minutes)

randaz gravatar image randaz  ( 2012-11-08 03:16:56 -0500 )edit

Any updates from the developers about this issue? Should I submit a ticket on github? Thank you

randaz gravatar image randaz  ( 2012-11-17 02:24:38 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2012-12-03 02:18:31 -0500

Confirmed memory leak (introduced in a recent commit). Just fixed it.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-11-07 06:22:59 -0500

Seen: 318 times

Last updated: Dec 03 '12