Ask Your Question
0

EffortJointInterface causes gazebo to segfault

asked 2018-12-30 04:41:55 -0500

robonoob gravatar image

updated 2018-12-30 10:01:23 -0500

gvdhoorn gravatar image

I'm trying to use <hardwareInterface>hardware_interface/EffortJointInterface</hardwareInterface> in my URDF but Gazebo crashes after starting the controllers. I thought i was doing something wrong, so i tried the RRBot demo and had the same issue: https://github.com/ros-simulation/gaz...

  • OS: Ubuntu 16.04
  • ROS Distro: Kinetic
  • ROS Version: 1.12.14
  • Gazebo Version: 7.14 (tried on 7.0 as well, same issue)

Error (with debug and verbose turned on):

Thread 37 "gzserver" received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7fff4effd700 (LWP 12785)]
0x00007fff11c7773d in gazebo_ros_control::DefaultRobotHWSim::readSim(ros::Time, ros::Duration) () from /home/bob/workspace/devel/lib//libdefault_robot_hw_sim.so
(gdb)

Is this a bug? I've noticed other people submitting issues on the repo with the same problem.

Thanks.

edit retag flag offensive close merge delete

Comments

It's a long shot, but do you have any outstanding updates to ROS packages? If so, please make sure to update all packages.

Also: are you running this in a Docker container?

gvdhoorn gravatar imagegvdhoorn ( 2018-12-30 10:02:08 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-12-30 17:42:06 -0500

robonoob gravatar image

@gvdhoorn, based on your suggestion, i removed my workspace, recreated it, reinstalled all the packages/libraries, and it's now working. Must have been a corrupt library or something. All good now. Thanks!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2018-12-30 04:41:55 -0500

Seen: 58 times

Last updated: Dec 30 '18