Ask Your Question
0

Gazebo plugin's UpdateChild() not being called?

asked 2012-11-07 05:29:59 -0600

Capelare gravatar image

updated 2014-01-28 17:14:11 -0600

ngrennan gravatar image

Hi, I'm writing plugins for NXT and Gazebo and I was having trouble with the one I'm currently working...

After some time I realized that UpdateChild is never executed, or so I think. I have some ROS_INFO("WTF"); calls that I use to follow the execution, and I can see the ones in LoadChild, InitChild and the callback node, but the one within UpdateChild is never shown.

This has not happened to me before, and I don't know what have I done differently...

BTW I'm using electric.

Here's the code for plugin that's not working, though you can also find it at my repository here, along with the rest of my packages.

This plugin takes the data from a camera and calculates the luminance of the image.

The launch file I'm executing is this one.

Thanks in advance,
Miguel.

Edit: I'm removing the code here for the sake of readability.

Also, I tried reducing the plugin to its minimal expression (removing all functionality) and still seems to ignore UpdateChild function. WTF is happening? Any hints? :S

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-11-17 08:14:05 -0600

Capelare gravatar image

I think I may have solved it. I just simply added the following lines to the plugin call in the URDF description:

<alwaysOn>true</alwaysOn>
<updateRate>${update_rate}</updateRate>

I didn't know that was necessary! :'(

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-11-07 05:29:59 -0600

Seen: 145 times

Last updated: Nov 17 '12