Ask Your Question
1

Rosinstall: multiple ros stacks error

asked 2012-11-05 01:14:34 -0500

michikarg gravatar image

updated 2014-04-20 14:09:25 -0500

ngrennan gravatar image

I was just trying to create a new ROS workspace on a computer in our University network using rosws init but I'm getting the following error:

$ rosws init . /opt/ros/fuerte/
Using ROS_ROOT: /opt/ros/fuerte/
Writing /usr/wiss/kargm/work/ros/.rosinstall
(Over-)Writing setup.sh, setup.bash, and setup.zsh in /usr/wiss/kargm/work/ros
ERROR in rosinstall: Multiple ros stacks found in config set(['/opt/ros/fuerte/share/ros', '/work/ros/fuerte/share/ros']), Please elimate all but one.
They come from the following sources: {'/opt/ros/fuerte/setup.sh': '/opt/ros/fuerte/share/ros', '/work/ros/fuerte/share/ros': '/work/ros/fuerte/share/ros'}

Apparently the problem is that in our case the /opt/ros/fuerte links to /work/ros/fuerte which is a standard configuration on the university machines to save space on the system partition. Anyhow I am wondering why rosinstall is complaining about a second ros stack on /work/ros/fuerte since I could not find any reference to it in any .rosinstall-file or any other files in the ROS workspacs... So how is this "config set" (which is mentioned in the error message) build? And how can I eliminate one of the ros stacks (preferably while keeping my current setting)?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2012-11-05 01:23:14 -0500

Lorenz gravatar image

I just analyzed the problem with our administrator and it turns out that rosws seems to have a bug related to /opt/ros being a symbolic link pointing to /work/ros. Filed here: https://github.com/vcstools/rosinstall/issues/22

edit flag offensive delete link more
0

answered 2012-11-05 01:19:04 -0500

dornhege gravatar image

updated 2012-11-05 01:20:42 -0500

The doubles origin from the fact that you initialize it in the /work/ros directory and pass /opt/ros/fuerte. I think rosinstall doesn't get that one symlinks the other.

Solution 1: Pass /work/ros/fuerte instead of /opt/ros/fuerte

Solution 2: Create your ROS workspace not in the /work/ros directory. Note: If that is a ROS system install you should not do that anyways.

edit flag offensive delete link more

Comments

I actually create the workspace in my home ~/work/ros (which links to /usr/wiss/kargm/work/ros on our NFS). The "/opt/ros/fuerte" ROS installation links to "/work/ros/fuerte" which is another partition. I should probably use other names to prevent confusion here...

michikarg gravatar image michikarg  ( 2012-11-05 01:24:36 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-11-05 01:14:34 -0500

Seen: 204 times

Last updated: Nov 05 '12