Ask Your Question
0

How do I get ROS to work on Chakra?

asked 2012-11-02 05:04:55 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I tried to install ROS on Chakra Linux. Following the installation instructions of http://www.ros.org/wiki/electric/Installation/Arch it aborted the installation because it didn´t detect the os. So I had to add -n for the desktop-full installation to get it work. Now, whenever I try to use rosdep install it keeps saying: rosdep ABORTING. Failed to detect OS: Could not detect OS, tried ['rosdep_test_os', 'debian', 'ubuntu', 'ubuntu', 'opensuse', 'fedora', 'rhel', 'arch', 'osx', 'osxbrew', 'gentoo', 'cygwin', 'freebsd']. How can I manually tell it, that the os is arch and make it install the necessary dependencies?

Additional info: I am using Linux 3.5.6-1-CHAKRA 64bit (Archimedes)

I hope someone can help me with this problem..

Mareike

edit retag flag offensive close merge delete

Comments

What is chakra linux? Never heard of it ... do you have a link to it? Thanks.

Kevin gravatar image Kevin  ( 2012-11-02 09:47:38 -0500 )edit

Chakra Linux is based on Arch Linux.. see http://chakra-project.org/ (you can find some more information under "About Chakra")

mareikep gravatar image mareikep  ( 2012-11-03 04:03:35 -0500 )edit

4 Answers

Sort by » oldest newest most voted
0

answered 2012-12-21 15:23:26 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

edit flag offensive delete link more
0

answered 2012-11-03 04:05:09 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Thanks for the answer but it still doesn´t work.. Using the first command returns rosdep: error: no such option: --os and the export command seems to not have any effect...

edit flag offensive delete link more

Comments

no ... it is an option. You are using fuerte and rosdep 2 right? Do a rosdep --help and you will see "--os" is an option. Did you type it just like I did: "--os=arch" with no spaces? If you are doing electric for some reason, then maybe it is not an option in rosdep 1.

Kevin gravatar image Kevin  ( 2012-11-03 04:16:27 -0500 )edit

Actually I am using electric.. so looks like I have to find another solution :(

mareikep gravatar image mareikep  ( 2012-11-03 06:24:53 -0500 )edit
0

answered 2012-11-02 09:46:37 -0500

Kevin gravatar image

Try:

rosdep install -ay --os=arch

The a is for all, y automatically says yes, and os tells rosdep the OS. You could also try:

export ROS_OS_OVERRIDE=arch
edit flag offensive delete link more
0

answered 2012-11-03 06:23:40 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Actually I am using electric.. so looks like I have to find another solution :(

edit flag offensive delete link more

Comments

Sorry ... I don't have electric installed ... try looking at rosdep --help and see if there is a similar way to specify the OS. I don't think there is. Good luck!!

Kevin gravatar image Kevin  ( 2012-11-03 07:03:34 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-11-02 05:04:55 -0500

Seen: 237 times

Last updated: Dec 21 '12