why roslaunch the gazebo failed. [closed]

asked 2012-10-27 05:09:37 -0600

hy2004ygx gravatar image

updated 2012-11-02 04:17:57 -0600

  1. sudo apt-get install ros-fuerte-simulator-gazebo
  2. source /opt/ros/fuerte/setup.bash
  3. roslaunch gazebo_worlds empty_world.launch

Connected to gazebo master @ http://localhost:11345 Error [Transport.cc:102] Unable to get topic namespaces in [50] tries. Error [Node.cc:68] No namespace found

It happens every time.Ever succeeded one time. How can I do,i can't make progress any more!

I had succeeded to study and execute 1-16 steps with the tutorials. One time after just opening computer, I roslaunched gazebo_worlds in success and appeared the GUI window,but then several minutes later it happened "No namespace found" again and GUI Windown disappeared. I did nothing at that time and the GUI was to my surprise!

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2013-06-13 13:06:10

Comments

how many times did this happen?

SL Remy gravatar image SL Remy  ( 2012-10-27 12:21:51 -0600 )edit

Did you do anything different before that one-time success?

Po-Jen Lai gravatar image Po-Jen Lai  ( 2012-11-01 01:25:58 -0600 )edit

Do you also happen to have any messages relating to GLX? If so what type of graphics card are you using and how are you connecting to the machine (e.g are you ssh'ing)

SL Remy gravatar image SL Remy  ( 2012-11-01 03:26:13 -0600 )edit

I got the same trouble with launching gazebo for the first time after installing. Now, the Error '[50] tries' and 'no namespace' happened everytime i launch anything gazebo- derived. Any help?

Tung Nguyen gravatar image Tung Nguyen  ( 2012-11-12 00:27:58 -0600 )edit

I cannot reproduce. If it's still an issue please ask a new question with more information about your computer configuration.

tfoote gravatar image tfoote  ( 2013-06-13 13:06:48 -0600 )edit