ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

installing ROS from source, actionlib error

asked 2012-10-26 04:18:45 -0500

I'm trying to install ROS from source. First problem that I ran into is that the git repo for actionlib does not exists any more.

Exception caught during install: Error processing 'actionlib' : [actionlib] Checkout of git:// version debian/ros-fuerte-actionlib_1.8.6_lucid into /home/gloin/ros-underlay/actionlib failed.

Does anybody know for some other repo for actionlib or how to continue with instalation process.

Thank you.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted

answered 2012-10-26 04:28:27 -0500

Lorenz gravatar image

Actionlib is now at To find the release repositories, you can have a look at the distro yaml files in the rosdistro repo. For fuerte, check out this file.

edit flag offensive delete link more


How do we submit a ticket for this? I asked on the user mailing list, but no answers yet. Not sure where to submit a ticket to ... it isn't an actionlib issue, but an install issue.

Kevin gravatar image Kevin  ( 2012-10-29 03:49:47 -0500 )edit


seanarm gravatar image seanarm  ( 2012-11-13 10:01:31 -0500 )edit

Hm. Good question. Maybe on the rosdistro github page?

Lorenz gravatar image Lorenz  ( 2012-11-13 20:56:02 -0500 )edit

answered 2012-10-28 23:38:55 -0500

If someone is having the same issue. This is how I fixed it. I downloaded the file from here: and then changed the first package:

- git:
    local-name: actionlib
    uri: git://
    version: debian/ros-fuerte-actionlib_1.8.7_precise

Then you should be able to run:

rosinstall --catkin ~/ros-underlay file://path_to/fuerte-ros-base.rosinstall
edit flag offensive delete link more

Question Tools


Asked: 2012-10-26 04:18:45 -0500

Seen: 1,865 times

Last updated: Oct 28 '12