Ask Your Question
2

Kinect dynamic reconfigure does not work

asked 2012-10-16 23:21:11 -0600

Antonio gravatar image

updated 2016-10-24 08:34:12 -0600

ngrennan gravatar image

Hi, I'm trying to follow the tutorial openni_launch for calibrating the Kinect, but when I launch the dynamic_reconfigure node and check the depth registration box it stops to publish images. When I uncheck the depth registration box it starts to publish again. Any idea to fix this? Are there some problem with the kinect driver? Thanks

edit retag flag offensive close merge delete

Comments

1

Same problem here. Is this a common bug because I see several people experiencing the same problem

yigit gravatar imageyigit ( 2012-10-17 03:46:20 -0600 )edit

Are there any update for the node available in the ros community to fix this problem?

Antonio gravatar imageAntonio ( 2012-10-17 04:52:54 -0600 )edit

I don't know for now but I am looking for a solution. If you find one, could you please share it here?

yigit gravatar imageyigit ( 2012-10-18 03:50:28 -0600 )edit

Sweet! I finally got it working

yigit gravatar imageyigit ( 2012-10-22 02:24:27 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
3

answered 2012-10-22 02:36:53 -0600

yigit gravatar image

updated 2012-10-22 02:37:58 -0600

I don't know why but when I installed openni_launch stack from ubuntu repos using the command below,

sudo apt-get install ros-fuerte-openni-launch ros-fuerte-openni-camera

the result is the same. Hovewer, when I tried to download the stacks from the kforge, it works. (This might be a bug in the ros-fuerte-openni-launch package, I am not sure.)

I recommend you to remove packages ros-fuerte-openni-camera and ros-fuerte-openni-launch using

sudo apt-get remove ros-fuerte-openni-launch ros-fuerte-openni-camera

and download them back using

hg clone https://kforge.ros.org/openni/openni_launch
hg clone https://kforge.ros.org/openni/openni_camera

These stacks are working for me.

edit flag offensive delete link more

Comments

Thank you very much it works also for me, maybe in these releases they have fixed the bug

Antonio gravatar imageAntonio ( 2012-10-24 05:31:38 -0600 )edit
0

answered 2012-10-22 06:13:27 -0600

I had the same problem, I was trying to visualize the point cloud on rviz, everything works perfectly with the depth unregistered, but, as it happens to you, as soon as I check the depth registration box it stops to work. I tried also to use the package downloaded with hg clone, but I have the same problem. This is probably a bug in the dynamic reconfigure GUI, my temporarily solution for now is to not use this GUI.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2012-10-16 23:21:11 -0600

Seen: 700 times

Last updated: Oct 22 '12