Ask Your Question
3

Rosdep update problems

asked 2012-10-16 02:28:20 -0500

michikarg gravatar image

Hey,

I just set up a fresh Fuerte Installation on Precise and tried to install rosdep using the deb-packages. I successfully ran:

sudo apt-get install python-rosdep
sudo rosdep init

but

rosdep update

returns:

ERROR: Rosdep experienced an internal error: [Errno 13] Permission denied: '/etc/ros/rosdep/sources.list.d'
Please go to the rosdep page [1] and file a bug report with the stack trace below.
[1] : http://www.ros.org/wiki/rosdep

Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.7/rosdep2/main.py", line 111, in rosdep_main
    exit_code = _rosdep_main(args)
  File "/usr/lib/pymodules/python2.7/rosdep2/main.py", line 230, in _rosdep_main
    return _no_args_handler(command, parser, options, args)
  File "/usr/lib/pymodules/python2.7/rosdep2/main.py", line 238, in _no_args_handler
    return command_handlers[command](options)
  File "/usr/lib/pymodules/python2.7/rosdep2/main.py", line 341, in command_update
    filelist = [f for f in os.listdir(sources_list_dir) if f.endswith('.list')]
OSError: [Errno 13] Permission denied: '/etc/ros/rosdep/sources.list.d'

Seems like rosdep is trying to write somewhere it has no permissions. It works when I do:

sudo rosdep update

But trying to use rosdep, it again tells, it is not initialized:

rosdep install libmove3d move3d_studio

ERROR: your rosdep installation has not been initialized yet.  Please run:

    sudo rosdep init
    rosdep update

I don't think there is something wrong with my setup, I just installed ROS Fuerte and rosws fresh, but still it seems to be a problem with my permissions... any idea?

edit retag flag offensive close merge delete

3 Answers

Sort by » oldest newest most voted
0

answered 2012-10-17 02:05:28 -0500

michikarg gravatar image

I just purged and installed again, same issue. My permissions are missing a read-permisson for others:

sudo ls -la /etc/ros/rosdep/sources.list.d
total 12
drwxr-xr-- 2 root root 4096 Oct 16 14:22 .
drwxr-x--- 3 root root 4096 Oct 16 14:08 ..
-rw-r----- 1 root root  557 Oct 16 14:22 20-default.list
edit flag offensive delete link more

Comments

Manually setting execution-permissions for others in /etc/ros/rosdep solved it for the moment, why have the permissions been set this way? Is there something wrong in the installation procedure?

michikarg gravatar image michikarg  ( 2012-10-17 02:14:26 -0500 )edit

Unless others confirm this bug, I'd say you had bad luck, e.g. those directories existed already, although I don't know what could have set them up..

felix k gravatar image felix k  ( 2012-10-17 03:43:49 -0500 )edit

Yes you're right, I will close this question for now and let's hope it was just a weird coincidence with my configuration...

michikarg gravatar image michikarg  ( 2012-10-17 04:41:18 -0500 )edit
3

answered 2012-10-30 13:00:21 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

FWIW, I had this same problem, and I was able to fix it using apt-get purge, then doing

sudo rm -rf $HOME/.ros/rosdep

and

sudo rm -rf /etc/ros/rosdep

Followed by a reinstall of python-rosdep using apt-get.

edit flag offensive delete link more

Comments

I had the same problem as michikarg, but your solution worked brilliantly for me. Just a note for others looking at this: don't forget to "sudo rosdep init" after reinstalling through apt-get! Many thanks!

georgebrindeiro gravatar image georgebrindeiro  ( 2013-01-08 04:09:55 -0500 )edit

I confirm having the same problem and it being solved as mentioned by dasid.

RayR gravatar image RayR  ( 2013-03-29 09:40:01 -0500 )edit

It works perfectly! I met the same issue and this is the correct solution:) I like it so much!

yuquan gravatar image yuquan  ( 2014-01-17 04:43:14 -0500 )edit
1

answered 2012-10-16 23:00:41 -0500

felix k gravatar image

Have you tried purging rosdep and installing it again?

Could you paste the permissions from that directory an its files on your system? Maybe they are really not listable resp. readable for everyone.

This is how it looks on mine:

$ ll /etc/ros/rosdep/sources.list.d
total 12
drwxr-xr-x 2 root root 4096 2012-03-16 11:41 ./
drwxr-xr-x 3 root root 4096 2012-03-16 11:41 ../
-rw-r--r-- 1 root root  409 2012-03-16 11:41 20-default.list
edit flag offensive delete link more

Comments

I just purged and installed again, same issue. My permissions are missing a read-permisson for others:

michikarg gravatar image michikarg  ( 2012-10-17 02:04:58 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2012-10-16 02:28:20 -0500

Seen: 4,290 times

Last updated: Oct 30 '12