Ask Your Question
0

[rosbridge_websocket.launch] is neither a launch file in package [rosbridge_server] nor is [rosbridge_server] a launch file name

asked 2021-04-01 21:59:27 -0500

trusktr gravatar image

updated 2021-04-02 00:02:41 -0500

Hello! I installed ros-melodic-desktop-full with apt-get and I am unable to start rosbridge. This is what I see:

vagrant@ubuntu-bionic:~$ apt list ros-melodic-rosbridge-*
Listing... Done
ros-melodic-rosbridge-library/bionic 0.11.13-1bionic.20210112.182152 amd64
ros-melodic-rosbridge-msgs/bionic 0.11.13-1bionic.20201211.203430 amd64
ros-melodic-rosbridge-server/bionic 0.11.13-1bionic.20210112.195018 amd64
ros-melodic-rosbridge-suite/bionic 0.11.13-1bionic.20210112.195104 amd64

vagrant@ubuntu-bionic:~$ rosdep db | grep rosbridge
rosbridge_suite -> ros-melodic-rosbridge-suite
rosbridge_server -> ros-melodic-rosbridge-server
rosbridge_msgs -> ros-melodic-rosbridge-msgs
rosbridge_library -> ros-melodic-rosbridge-library

vagrant@ubuntu-bionic:~$ roslaunch rosbridge_server rosbridge_websocket.launch
RLException: [rosbridge_websocket.launch] is neither a launch file in package [rosbridge_server] nor is [rosbridge_server] a launch file name
The traceback for the exception was written to the log file

All other answers I can find that are at all similar all say to source ~/catkin_ws/devel/setup.bash, but I have no such file. I haven't used catkin, just apt-get. I see no devel/setup.sh file anywhere:

vagrant@ubuntu-bionic:~$ locate ros | grep setup.sh
/opt/ros/melodic/local_setup.sh
/opt/ros/melodic/setup.sh
/opt/ros/melodic/share/catkin/cmake/templates/local_setup.sh.in
/opt/ros/melodic/share/catkin/cmake/templates/setup.sh.in

What may be missing?

EDIT: I now tried to do the following without any luck:

$ cd ~/ros_ws
$ catkin_make
... successful output ...
$ source ~/ros_ws/devel/setup.bash
$ roslaunch rosbridge_server rosbridge_websocket.launch
RLException: [rosbridge_websocket.launch] is neither a launch file in package [rosbridge_server] nor is [rosbridge_server] a launch file name
The traceback for the exception was written to the log file

This is not easy for ROS newbies. No idea what I'm missing yet, and the documentation hasn't led to any clues.

edit retag flag offensive close merge delete

Comments

1

apt list ros-melodic-rosbridge-* lists available packages, not installed packages (they would be noted as such):

Listing... Done
ros-melodic-rosbridge-library/bionic,now 0.11.13-1bionic.20210112.182152 amd64 [installed]
ros-melodic-rosbridge-msgs/bionic,now 0.11.13-1bionic.20201211.203430 amd64 [installed,automatic]
ros-melodic-rosbridge-server/bionic,now 0.11.13-1bionic.20210112.195018 amd64 [installed]
ros-melodic-rosbridge-suite/bionic,now 0.11.13-1bionic.20210112.195104 amd64 [installed]

You can either check that they say "installed", or you can use the --installed flag (apt list --installed ros-melodic-rosbridge-*) to only show installed packages that meet your criteria. The output will be similar.

tryan gravatar image tryan  ( 2021-04-02 08:59:40 -0500 )edit
1

That was it. I naively thought "desktop-full" meant it came with everything. I also didn't realize I needed the --install param to apt list. Thanks!

trusktr gravatar image trusktr  ( 2021-04-02 17:12:37 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2021-04-02 00:42:32 -0500

abhishek47 gravatar image

What's the output of rospack find rosbridge_server? If it's not a directory location, then either the package is missing or not visible.

ros-melodic-desktop-full doesn't have RosBridge, you'd have to install it separately using sudo apt-get install ros-melodic-rosbridge-suite (check out RosBridge tutorial).

After installing RosBridge, re-source ROS and then try launching rosbridge_websocket.launch.

edit flag offensive delete link more

Comments

1

That was it. I for some reason thought "ros-melodic-desktop-full" implied it came with "everything".

After installing ros-melodic-rosbridge-*, then roslaunch rosbridge_server rosbridge_websocket.launch worked.

Thanks!

trusktr gravatar image trusktr  ( 2021-04-02 17:11:17 -0500 )edit
0

answered 2021-04-02 07:18:30 -0500

gvdhoorn gravatar image

updated 2021-04-02 07:19:38 -0500

This is not easy for ROS newbies. No idea what I'm missing yet, and the documentation hasn't led to any clues.

Did you notice the Setting up the environment section in the installation tutorial?

Specifically this part:

Environment setup

It's convenient if the ROS environment variables are automatically added to your bash session every time a new shell is launched:

echo "source /opt/ros/melodic/setup.bash" >> ~/.bashrc
source ~/.bashrc

''If you have more than one ROS distribution installed, ~/.bashrc must only source the setup.bash for the version you are currently using.''

If you just want to change the environment of your current shell, instead of the above you can type:

source /opt/ros/melodic/setup.bash
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2021-04-01 21:59:27 -0500

Seen: 1,273 times

Last updated: Apr 02 '21