Ask Your Question
1

ROS Core build on arch Linux

asked 2012-10-12 00:08:39 -0500

vijay gravatar image

updated 2014-01-28 17:13:55 -0500

ngrennan gravatar image

Hi all,

I get the following error when i build the ROS core on a arch linux x86_64 system. I do not know much but a bit of googling pointed me to believe that this could be a boost lib problem that should have been solved in version 1.50 of boost which i have installed but no luck. If someone could help me solve this would be helpful.

Thanks

The Error is below:

Building CXX object ros_comm/tools/rosbag/CMakeFiles/rosbag.dir/src/recorder.cpp.o
/home/zion/ros-underlay/ros_comm/tools/rosbag/src/recorder.cpp: In member function 'void rosbag::Recorder::doRecord()':
/home/zion/ros-underlay/ros_comm/tools/rosbag/src/recorder.cpp:439:42: error: expected unqualified-id before numeric constant
make[2]: *** [ros_comm/tools/rosbag/CMakeFiles/rosbag.dir/src/recorder.cpp.o] Error 1
make[1]: *** [ros_comm/tools/rosbag/CMakeFiles/rosbag.dir/all] Error 2
make: *** [all] Error 2
edit retag flag offensive close merge delete

Comments

I encountered the same problem when installing ROS from the sources with rosinstall.

Lukas Bulwahn gravatar image Lukas Bulwahn  ( 2012-12-05 22:58:02 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
0

answered 2012-10-12 06:56:00 -0500

Lorenz gravatar image

That is interesting. So the corresponding line in the cpp file is:

#if BOOST_VERSION >= 105000

I wonder what BOOST_VERSION expands to. I would actually just manually patch the c++ file locally. Just get rid of the #if, #else and #endif lines and keep the code in the if block in case your boost version is greater or equal than 1.50.

That's sort of an ugly hack but I guess the quickest way to get ROS compiled.

edit flag offensive delete link more

Comments

Hi Lorenz, Could not find the # if BOOST_VERSION anywhere in the source :( i tried grep -rl '#if BOOST' .

vijay gravatar image vijay  ( 2012-10-13 23:57:54 -0500 )edit

Hi All, Could anyone help me for the entries that Lorenz is talking about ? Thanks

vijay gravatar image vijay  ( 2012-10-16 12:31:40 -0500 )edit

I did not understand the answer either before looking at https://github.com/ros/ros_comm/issues/10

Lukas Bulwahn gravatar image Lukas Bulwahn  ( 2012-12-05 22:58:26 -0500 )edit
0

answered 2012-12-06 02:02:28 -0500

Lukas Bulwahn gravatar image

updated 2012-12-06 02:02:54 -0500

The answer from Lorenz is correct, but Lorenz was pointing at the development version where things have been fixed. However in the fuerte release version, it is not fixed.

Nevertheless, simply apply the patch http://pastebin.com/ZFDD4Qhs in your ros_comm directory.

edit flag offensive delete link more
0

answered 2012-12-07 12:37:49 -0500

yoos gravatar image

Another (cleaner?) fix is to change TIME_UTC in recorder.cpp to TIME_UTC_

This forum post might shed some more light on the problem: https://bbs.archlinux.org/viewtopic.php?id=144593

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-10-12 00:08:39 -0500

Seen: 487 times

Last updated: Dec 07 '12