ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Arch x86_64 Linux ROS core build fails

asked 2012-10-09 01:03:18 -0500

vijay gravatar image

updated 2016-10-24 09:00:37 -0500

ngrennan gravatar image


When i try to build the ROS core on Arch Linux x86_64 system i get the following error, if some one could help me solve this or at least point me in the rite direction would be very helpful

The error is below:

Linking CXX executable ../../bin/rxloggerlevel
[100%] Built target rxconsole
In file included from /tmp/yaourt-tmp-zion/aur-ros-core/src/ros-underlay/build/rx/rxtools/rosout_panel_swig_generated.cpp:3240:0:
/usr/include/wx-2.8/wx/wxPython/wxPython.h: In function 'bool wxPyCoreAPI_IMPORT()':
/usr/include/wx-2.8/wx/wxPython/wxPython.h:39:80: error: 'PyCObject_Import' was not declared in this scope
[100%] Built target rxloggerlevel
make[2]: *** [rx/rxtools/CMakeFiles/python_rxtools.dir/rosout_panel_swig_generated.cpp.o] Error 1
make[1]: *** [rx/rxtools/CMakeFiles/python_rxtools.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....
Linking CXX shared library ../../../lib/
[100%] Built target rosbag
make: *** [all] Error 2
edit retag flag offensive close merge delete


Take a look here.. it may be a new swig issue in rxtool... good luck.

SL Remy gravatar image SL Remy  ( 2012-10-09 06:35:32 -0500 )edit

Hi Lorenz, Thanks for your response, i tried cmake -DCMAKE_INSTALL_PREFIX=/opt/ros/fuerte -DSETUPTOOLS_DEB_LAYOUT=OFF -DPYTHON_EXECUTABLE=/usr/bin/python2 .. looked for any reference to python in the build directory there was none but i still get the same errro :( any ideas

vijay gravatar image vijay  ( 2012-10-10 23:30:54 -0500 )edit

Have a look at CMakeCache.txt. There should be something related to libpython.

Lorenz gravatar image Lorenz  ( 2012-10-11 00:11:52 -0500 )edit

Thanks Lorenz looks like that solved the python problem but now i face a boost problem i think

vijay gravatar image vijay  ( 2012-10-12 00:21:22 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted

answered 2012-10-09 01:29:38 -0500

Lorenz gravatar image

That seems to be another python issue. My guess is that cmake's configure finds python3 instead of python2. If you are lucky, you can change that using ccmake. Go into your build directory, execute cmake . and check if the configure contains something python3 related. Change it to the corresponding files/directories/flags for python2. If that doesn't work, you might have to patch some catkin cmake files that are responsible for finding python.

edit flag offensive delete link more

answered 2014-01-29 00:38:39 -0500

bchr gravatar image

Since this problem is still relevant with Groovy/Hydro for some packages, a script that automatically fixes these issues is available in ros-build-tools. Calling on the source directory before installing it solves it, but this means that all ROS packages have to be fixed that way when installing ROS. This is done automatically in dedicated AUR packages.

edit flag offensive delete link more

Question Tools


Asked: 2012-10-09 01:03:18 -0500

Seen: 534 times

Last updated: Jan 29 '14