ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A answers.ros.org
Ask Your Question
0

I can't use rosdep?!

asked 2012-10-08 04:13:32 -0600

roskidos gravatar image

updated 2012-10-08 13:34:15 -0600

mjcarroll gravatar image

I'm a beginner of Ubuntu (v12.04) and Fuerte ROS.

I've tried several tutorials in ROS and mostly things were OK.

Now, I'm trying to build some stacks i.e. robotino*. But I cannot use rosdep.

rosdeps: command not found

Did I install ROS incorrectly or lack of some steps to initialize ROS platform?

Thank you!

edit retag flag offensive close merge delete

Comments

I've tried to track the error and see that I'm lack of rosbash. So I run "source ${ROS_ROOT}/tools/rosbash/rosbash" but the error comes "No such file or directory"

roskidos gravatar image roskidos  ( 2012-10-08 04:33:35 -0600 )edit

Have a look at the environment setup section and the overlay page. You probably don't have your environment set up correctly.

Lorenz gravatar image Lorenz  ( 2012-10-08 04:43:14 -0600 )edit

thank you @Lorenz!! I've found that I perhaps was lacked of this command in the installation page of ROS: sudo apt-get install python-rosinstall python-rosdep

roskidos gravatar image roskidos  ( 2012-10-08 04:56:23 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
4

answered 2012-10-08 04:29:32 -0600

Lorenz gravatar image

The command is not rosdeps but rosdep. You need to install rosdep with:

sudo apt-get install python-rosdep
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2012-10-08 04:13:32 -0600

Seen: 1,452 times

Last updated: Oct 08 '12