Ask Your Question
0

setting min depth in openni_kinect

asked 2012-10-08 00:48:04 -0500

updated 2016-10-24 09:08:28 -0500

ngrennan gravatar image

How do you setup minimum still acceptable depth in openni_kinect. The problem is when trying to simulate Turtlebot and building maps with SLAM. Min depth is set too low and simulated laser picks up turtlebot itself resulting in poorly build maps.

Or can I adjust minimum depth somewhere else?

Thank you.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-10-08 02:07:17 -0500

I have found the solution. Needed to change parameters in turtlebot_description in gazebo.urdf.xacro under <xacro:macro name="turtlebot_sim_laser">

<minRange>0.30</minRange>

I also modified the angle of simulated laser, because it was way to big:

<minAngle>-57</minAngle>
<maxAngle>57</maxAngle>
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-10-08 00:48:04 -0500

Seen: 142 times

Last updated: Oct 08 '12