Ask Your Question
0

I type command of ROS,but no reaction!

asked 2012-10-07 21:13:21 -0500

bobliao gravatar image

updated 2012-10-07 23:48:30 -0500

This phonemenon seldom occurs,but i have seen it several times in the past months. my operations are followings:

  1. Start my ubuntu,then open a terminal
  2. I type "roscore",however nothing appears...

after i wait about several minutes .i see the following,and i go on my waiting :

... logging to /home/bobliao/.ros/log/49c47ac0-1117-11e2-976a-74ea3a7e2629/roslaunch-bob-r-2600.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

after 10 minutes , it prints the error info ,and that's an error of MASTER_URI configuration problem. but why this error make the terminal so slow?there must be something else,as ordinary it will print the error immediately.

i am only working on the single mode,all the ros nodes are on the same machine. here , i paste related lines of my .bashrc file :

export ROS_PACKAGE_PATH=$ROS_PACKAGE_PATH:~/fuerte/

export ROS_WORKSPACE=~/fuerte

source /opt/ros/fuerte/setup.bash

export ROS_MASTER_URI=http://192.168.1.101:11311

export ROS_HOSTNAME=192.168.1.101

my network configuration:on PC,i use a wireless card,connected to a router.and when i run my PC,the IP may change when the PC is running ,i think this lead to the failure of network. but it cost much time to print error,makes me confusd.

thank you for your detail reply,Shanmugasivam Pillai!

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
3

answered 2012-10-07 23:27:09 -0500

Hi,

While on one side you have this issue of network problems that leads to a failure in initialization there is also an unwanted delay. For your network issue you may want to check with the link provided by @Thomas

However, for quick troubleshooting, are you running roscore in a multi machine setup? In that case have you set the variable ROS_MASTER_URI to point the appropriate machine? If its a single machine is there are problem with the ip address of the localhost that should be mentioned in /etc/hosts ?

For the problem of delay you have in your system I highly doubt that it has got something to do with the .bashrc file of yours. When you open the terminal does it take quiet longer than usual to just start up into your home directory? In that case you must check your .bashrc file for unwanted lines, mostly added in the end.

I may be able to improve my answer if you could update your question with more relevant information.

Hope that helps.

Regards.

edit flag offensive delete link more
2

answered 2012-10-07 23:59:45 -0500

Ben_S gravatar image

Maybe its so slow because all the network-requests need to time out before it can print the errors.

You should make sure, that your IP will be static and does not change when rebooting/reconnecting to your router. Either by setting it manually on your pc or by defining a static MAC<->IP mapping in your dhcp server (most likely your router).

Besides that it would be advisable to set ROS_IP rather than ROS_HOSTNAME when using an IP-address. (Network related environment variables)

edit flag offensive delete link more
1

answered 2012-10-07 21:38:58 -0500

Thomas gravatar image

This problems seems to be a network related. You should probably check the network setup and see if it solves your issue.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-10-07 21:13:21 -0500

Seen: 378 times

Last updated: Oct 07 '12