ROS Problems with the Barrett WAM - ROSCPP Tutorials not found + No Graphics Card to Support Graphical Libraries [closed]

asked 2012-09-27 14:23:30 -0600

GraceC gravatar image

updated 2012-09-27 14:25:22 -0600

I was following the "ROS across Multiple Machines" tutorial when the Barrett WAM ran into the issue of not being able to run the command "rosrun rospy_tutorials listener"

It turns out, the WAM couldn't find rospy_tutorials. So, I decided to go through the tutorials to see what all I can do.

Note: I installed a bare-bones install of ROS because the Barrett WAM doesn't have a graphics card to support the graphical libraries.

//Following the tutorials of ros commands, here is where I run into problems:
~/.ros/log$ rosls roscpp_tutorials
//Lists six lines like 1222f7ac-08ea-11e2-b8ec-0007320e7f37 instead of 
//bin, cmake, manifest.xml, srv
~/.ros/log$ rosrun roscpp_tutorials listener
[rospack] Error: stack/package roscpp_tutorials not found

I do not know how to install a Full ROS install minus the graphical libraries. I think this would solve the problem.

However, when I tried to install individual stacks, the WAM said that the stack named could not be found (ros_tutorials). Maybe I did this incorrectly.

How do I get ROS fully working on my Barrett WAM so I can use it to its full potential?

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2015-06-30 19:03:28.458336