Ask Your Question
2

Bootstrapping a Groovy install?

asked 2012-09-26 04:31:01 -0500

jamuraa gravatar image

updated 2012-11-29 15:10:43 -0500

Kevin gravatar image

I've been trying to get a groovy install running, from scratch / source, and I have found a couple of tutorials for starting from catkin, but none of them work. I have tried these on Ubuntu precise, and also just from source on Debian sid.

I've tried:

http://ros.org/doc/groovy/api/catkin/html/dev_guide/underlay.html - There is no python-catkin-pkg package that I can find on Ubuntu or in the package build repository, and if I ignore it, I get an error later in the process about not finding a python module named catkin_pkg.package.

After some help finding catkin_pkg (http://github.com/ros-infastructure/catkin_pkg) and installing it, I run into a second issue with the instructions, when I'm running cmake ../src, it ends with this error:

CMake Error at /home/jamuraa/tmp/testing/groovy-install/build/buildspace/share/catkin/cmake/catkinConfig.cmake:76 (find_package):
  Could not find a package configuration file provided by "std_msgs" with any
  of the following names:

    std_msgsConfig.cmake
    std_msgs-config.cmake

  Add the installation prefix of "std_msgs" to CMAKE_PREFIX_PATH or set
  "std_msgs_DIR" to a directory containing one of the above files.  If
  "std_msgs" provides a separate development package or SDK, be sure it has
  been installed.
Call Stack (most recent call first):
  ros_comm/tools/rosmaster/CMakeLists.txt:5 (find_package)

This looks like it's trying to find the std_msgs package before it has discovered it, but after looking around for a while, I don't quite know enough about catkin internals to figure out what is causing it.

Is there a document somewhere for how to bootstrap a Groovy Galapagos ROS install for testing / development?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2012-09-26 05:46:29 -0500

KruseT gravatar image

updated 2012-09-26 23:30:37 -0500

Maybe this link can help: https://github.com/ros/catkin/issues/175

The deb can be downloaded and installed like this:

$ wget http://packages.ros.org/ros-shadow-fixed/ubuntu/pool/main/c/catkinpkg/python-catkin-pkg_0.1.0-1_all.deb
$ sudo dpkg -i python-catkin-pkg_0.1.0-1_all.deb

I ended up downloading the sources and installing manually using

$ sudo python setup.py install

But I needed an install from source anyway.

EDIT: What you describe could be a bug in the dependencies. catkin needs to create std_msgsConfig.cmake before using it, so if some package (rosmaster) uses std_sgs in the CMakeLists.txt, but does not declare that dependency in the package.xml, this error would occur. This occurs for ros_comm/rosmaster. Since catkin is very much in flux right now, you can either report this or wait a day until it got fixed.

A simple update (rosws update -j8 in src) could do the trick. As I said, this is very much in flux right now, as the catkin design has been changed a lot, and a lot of packages need to be migrated.

edit flag offensive delete link more

Comments

Thanks for this informed explanation. If I wanted to help fix the dependency problem, could I branch and send pull requests to places somehow, or is it more recommended at this point to just wait until the dust settles a little more?

jamuraa gravatar image jamuraa  ( 2012-09-27 12:45:39 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-09-26 04:31:01 -0500

Seen: 516 times

Last updated: Sep 26 '12