Ask Your Question
2

Problem installing OpenNI driver

asked 2013-08-04 15:37:40 -0500

Andrew.A gravatar image

updated 2013-08-04 15:41:48 -0500

Hi all,

I'm trying to install drivers for my Primesense device (Asus Xtion Pro Live), but I'm getting a problem running the install.sh file. I'm running Groovy on Ubuntu 12.10.

After days of research, I realised there were two versions of the driver, one was from the openni.org website, and there was another version of it done by avin2 (https://github.com/avin2/SensorKinect). I finally realised the avin2 one was for Kinect, and the openni.org one was for other Primesense devices (source here: https://groups.google.com/forum/#!topic/openni-dev/Nw8J9WtRTTI, and https://code.google.com/p/simple-openni/wiki/Installation#Linux).

So, I downloaded the 32bit tarball from openni.org:

http://www.openni.org/wp-content/uploads/2012/12/Sensor-Bin-Linux-x86-v5.1.2.1.tar.zip

Unfortunately, I'm getting an error running ./install.sh. Here's what it looks like:

$ sudo ./install.sh 
Installing PrimeSense Sensor
****************************

creating config dir /usr/etc/primesense...OK
copying shared libraries...OK
copying executables...OK
registering module 'libXnDeviceSensorV2.so' with OpenNI..../install.sh: 105: ./install.sh: /usr/bin/niReg: not found

Does anyone know how to fix this? I tried to sudo mkdir /usr/bin/niReg, but I'd still get an error running ./install.sh; it now becomes permission denied:

$ sudo ./install.sh 
Installing PrimeSense Sensor
****************************

creating config dir /usr/etc/primesense...OK
copying shared libraries...OK
copying executables...OK
registering module 'libXnDeviceSensorV2.so' with OpenNI..../install.sh: 106: ./install.sh: /usr/bin/niReg: Permission denied

Please help! Thanks

edit retag flag offensive close merge delete

Comments

I also faced the same problem. Does anyone have a solution? I'm using Ubuntu 12.04 and Xtion. I had downloaded 32bit version of OpenNI2.2 and Sensorv5.1.2.1.

TomHsu1990 gravatar imageTomHsu1990 ( 2013-08-16 22:10:14 -0500 )edit

If I'm not mistaken, I think I read somewhere that the drivers (Sensor v5.1.2.1) only needs to be installed with the old version of OpenNI (v.1.5.4). The reason why it says the module is not found is because it only comes with OpenNI v1.5.4.

Andrew.A gravatar imageAndrew.A ( 2013-08-19 16:30:34 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2013-08-19 16:35:56 -0500

Andrew.A gravatar image

The error occurred because I was trying to install the drivers with OpenNI 2.2 (which is not required). The drivers are only for the older version of OpenNI, v1.5.4.

edit flag offensive delete link more

Comments

My other question at http://answers.ros.org/question/70585/roslaunch-openni_launch-opennilaunch-no-devices-connected/ has help on how to get the drivers for v1.5 working.

Andrew.A gravatar imageAndrew.A ( 2013-12-22 21:15:36 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-08-04 15:37:40 -0500

Seen: 4,407 times

Last updated: Aug 19 '13