Ask Your Question
0

Did I Break the Build?

asked 2012-09-18 08:01:20 -0500

David Lu gravatar image

I'm working on releasing my stacks to electric (since that's what they've been most tested on) and I got this email.

Internal failure release system. Please notify leibs and kwc @willowgarage.com: Problem fetching yaml info for object_recognition None (https://code.ros.org/svn/release/download/stacks/object_recognition/object_recognition-None/object_recognition-None.yaml)

Traceback (most recent call last):

blah blah blah
raise Exception("Problem fetching yaml info for %s %s (%s)"%(stack_name, stack_version, url))

Exception: Problem fetching yaml info for object_recognition None (https://code.ros.org/svn/release/download/stacks/object_recognition/object_recognition-None/object_recognition-None.yaml)

None

http://build.willowgarage.com/job/debbuild-build-debs-electric-lucid-i386/1179/

Upon viewing the link there, I see my changes (#1 and #12) but I'm unsure if this is my fault. Is this something I should fix?

Also, (possibly unrelated) what relation does the above page have to this page: the electric build status page (as linked from the release wiki page)

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2012-09-18 22:26:33 -0500

tfoote gravatar image

No, object_recognition had an invalid version it should have been null not None. Fixed now.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-09-18 08:01:20 -0500

Seen: 95 times

Last updated: Sep 18 '12