Ask Your Question
2

"rosrun rgbdslam rgbdslam" symbol lookup error, fuerte

asked 2012-09-12 23:05:36 -0600

marvin gravatar image

updated 2014-01-28 17:13:38 -0600

ngrennan gravatar image

Hi,

after compiling rgbdslam successfully, I tried to start rgbdslam. All I got was a "symbol lookup error":

/home/robot/ros/rgbdslam/bin/rgbdslam: symbol lookup error: /home/robot/ros/rgbdslam/lib/libgicp.so: undefined symbol: gsl_multimin_fdfminimizer_vector_bfgs2

After searching the web for a while I found a related topic here.

So I changed the LD_LIBRARY_PATH to /opt/ros/fuerte/lib:/usr/lib and exported it but I didn't fix the error.

GSL Version:libgsl0ldbl 1.15+dfsg-1build1 ROS Fuerte Ubuntu 12.04

Can somebody help me?

Cheers! Georg

edit retag flag offensive close merge delete

Comments

are these packages installed "gsl-bin libgsl0-dev"?

yigit gravatar imageyigit ( 2012-09-13 01:38:45 -0600 )edit

yes, they are installed.

marvin gravatar imagemarvin ( 2012-09-13 02:30:55 -0600 )edit

weird, that is a runtime error or a linker error?

Felix Endres gravatar imageFelix Endres ( 2012-09-24 11:19:51 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2013-01-02 09:07:19 -0600

Could be that you need to deinstall ros-fuerte-libg2o (and rebuild rgbdslam)

edit flag offensive delete link more
0

answered 2013-01-01 05:56:27 -0600

codeit gravatar image

I tried running

roslaunch openni_launch openni.launch ..... this runs with out issues

but then

george@ulisa:~$ rosrun rgbdslam rgbdslam /home/george/fuerte_workspace/rgbdslam_freiburg/rgbdslam/bin/rgbdslam: Symbol `_ZTVN3g2o19UniformCostFunctionE' has different size in shared object, consider re-linking /home/george/fuerte_workspace/rgbdslam_freiburg/rgbdslam/bin/rgbdslam: symbol lookup error: /home/george/fuerte_workspace/rgbdslam_freiburg/rgbdslam/bin/rgbdslam: undefined symbol: _ZN3g2o11globalStatsE

I am new to ROS .. what causing this ?? By the way I had run this few months back and it had worked .. I cant understand whats happening now.

edit flag offensive delete link more

Comments

Please post a new question in a new thread. It will be helpful for others who have the same error to find the information they need.

yigit gravatar imageyigit ( 2013-01-01 09:22:17 -0600 )edit

I think I have the same error.... symbol lookup error ..... do know how to get correct it ? @yygyt

codeit gravatar imagecodeit ( 2013-01-02 01:39:12 -0600 )edit

yes g2o was the culprit

codeit gravatar imagecodeit ( 2013-01-10 05:14:52 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2012-09-12 23:05:36 -0600

Seen: 471 times

Last updated: Jan 01 '13