Ask Your Question
1

Cannot Install ROS Electric Desktop-Full on Oneiric AMD64 - In Dependency Hell

asked 2012-09-12 08:03:56 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

stephanie@WorkTime:~$ sudo apt-get install ros-electric-desktop-full
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ros-electric-desktop-full : Depends: ros-electric-slam-gmapping (= 1.2.5-s1336543727~oneiric) but it is not going to be installed
                             Depends: ros-electric-vision-opencv (= 1.6.13-s1336531637~oneiric) but it is not going to be installed
                             Depends: ros-electric-perception-pcl (= 1.0.2-s1336532338~oneiric) but it is not going to be installed
                             Depends: ros-electric-image-pipeline (= 1.6.4-s1336532075~oneiric) but it is not going to be installed
                             Depends: ros-electric-simulator-gazebo (= 1.4.15-s1338549736~oneiric) but it is not going to be installed
                             Depends: ros-electric-image-transport-plugins (= 1.4.2-s1336531748~oneiric) but it is not going to be installed
                             Depends: ros-electric-navigation (= 1.6.5-s1336537141~oneiric) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
stephanie@WorkTime:~$ sudo apt-get install ros-electric-slam-gmapping ros-electric-vision-opencv ros-electric-image-pipeline ros-electric-simulator-gazebo ros-electric-image-transport-plugins ros-electric-navigation
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ros-electric-navigation : Depends: ros-electric-perception-pcl (= 1.0.2-s1336532338~oneiric) but it is not going to be installed
                           Depends: libsdl-image1.2-dev but it is not going to be installed
 ros-electric-simulator-gazebo : Depends: ros-electric-perception-pcl (= 1.0.2-s1336532338~oneiric) but it is not going to be installed
 ros-electric-vision-opencv : Depends: libopencv2.3-dev (= 2.3.1+svn6514+branch23-12~oneiric) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
stephanie@WorkTime:~$ sudo apt-get install libopencv2.3-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libopencv2.3-dev : Depends: libtiff4-dev but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
stephanie@WorkTime:~$ sudo apt-get install libopencv2.3-dev libtiff4-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libtiff4-dev is already the newest version.
libtiff4-dev set to manually installed.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages ...
(more)
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
3

answered 2012-09-12 08:55:13 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

It looks like someone upgraded your Ubuntu oneiric install to precise (12.04 LTS) while you weren't looking. Try installing fuerte's precise repo as described at http://www.ros.org/wiki/fuerte/Installation/Ubuntu.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2012-09-12 08:03:56 -0500

Seen: 376 times

Last updated: Sep 12 '12