Ask Your Question
0

Writing a Teleoperation Node for a Linux-Supported Joystick

asked 2012-09-05 10:58:20 -0500

jcparrad gravatar image

Hi. I am starting learning ROS. I want to do the tutorial "Writing a Teleoperation Node for a Linux-Supported Joystick" in http://www.ros.org/wiki/joy/Tutorials/WritingTeleopNode but when i try to run the command "roslaunch learning_joy turtle_joy.launch" I get

ERROR: cannot launch node of type [learning_joy/turtle_teleop_joy]: can't locate node [turtle_teleop_joy] in package [learning_joy]

I appreciate your help a lot

edit retag flag offensive close merge delete

Comments

I am getting the exact same error.

But, if you go to ~/catkin_ws/ and

catkin_make

you get the build files in ~/catkin_ws/build/learning_joy

Run the executable using:

./turtle_teleop_joy

Make sure you do

rosrun turtlesim turtlesim_node

rosrun joy joy_node

Also initialize the l_scale_ and a_scale_ variables to some integer (I made them 10).

I still get the same error when I try using the launch file. Please help if anyone got to know why this happens.

mahathi92 gravatar image mahathi92  ( 2020-10-16 06:04:18 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
3

answered 2012-09-05 11:32:01 -0500

The tutorial doesn't explicitly tell you to compile your code, but you should make sure to run the command

rosmake learning_joy
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-09-05 10:58:20 -0500

Seen: 544 times

Last updated: Sep 05 '12