ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Pointcloud_to_Laserscan correctly installed?

asked 2012-09-05 05:29:27 -0500

Flowers gravatar image

updated 2012-09-05 22:09:43 -0500

Hey guys,

I'd like to use the pointcloud_to_laserscan package to downgrade the PCL-Data, that I get from a Kinect, and use the 2D-Scan for the navigation stack.

Right now, I'm not sure, if I installed pointcloud_to_laserscan correctly. I have downloaded the files( and have run rosmake(no errors).

The auto-fill-in function of rosrun works fine - I can find the package.

Eventhough the "nodes" I could launch are a little awkward - "CloudScan.cfg" and "" do not seem correct.

cliffs: -tried install PCL_to_Laserscan -rosmake without error -package found by roscd, rosrun, etc -nodes seem wrong(*.cfg and *.so)

Edit: So, the nodes seem fine - how do I run them?! CloudScan.cfg just creates some reconfiguration files and with libcloud_to_scan I get some memory error - guess the translation is segmentation fault.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2012-09-05 05:32:12 -0500

dornhege gravatar image

The "nodes" are OK. rosrun just looks for anything executable, including libraries and the .cfg script.

edit flag offensive delete link more


thx, still...I get an error(-> see edit above)

Flowers gravatar image Flowers  ( 2012-09-05 22:13:42 -0500 )edit

Well, you shouldn't/can't run those as ROS nodes. The package you linked to actually provides two nodelets, so you'll need to load them as such. Here is an example:

dornhege gravatar image dornhege  ( 2012-09-05 23:47:14 -0500 )edit

Question Tools


Asked: 2012-09-05 05:29:27 -0500

Seen: 652 times

Last updated: Sep 05 '12