Ask Your Question
0

Unable to do teleop

asked 2012-08-30 02:27:44 -0500

Arjun PE gravatar image

updated 2014-01-28 17:13:30 -0500

ngrennan gravatar image

Hi all,

I am unable to move husky (even the teleop operation). The pc connected in husky has fuerte installed in it. When I try to run husky from my pc, which has electric in it, it isn't working.

The teleop works perfectly from the Husky PC.

When I try to run teleop after making Husky as my master, from my pc and move the joystick, then I am able to see the values in my PC through the following topic :-

rostopic echo /husky/cmd_vel

But the husky is not moving.

I connected the joystick to the husky's pc and moved it, I was able to see those values from my PC.

I also tried to publish the cmd_vel manually using :-

rostopic pub /husky/cmd_vel geometry_msgs/Twist -r 10 '[0.0,0.0,0.0]' '[0.0,0.0,1.0]'

Then it is getting published, but still husky is not moving.

Any help would be highly appreciated. Thanks in advance

edit retag flag offensive close merge delete

Comments

1

Does running teleop from the Husky PC work?

Ryan gravatar imageRyan ( 2012-08-30 02:36:07 -0500 )edit

@Ryan Yes, it works from the Husky PC

Arjun PE gravatar imageArjun PE ( 2012-08-30 02:42:13 -0500 )edit

When you publish them from the joystick on the PC, try SSHing into the Husky PC and echoing /husky/cmd_vel there - this may be an Electric/Fuerte compatibility issue.

Ryan gravatar imageRyan ( 2012-08-30 05:51:49 -0500 )edit

I tried sshING, and it is working. Thank you for the idea. I think we should start a new thread for the compatibility issue. Regards.

Arjun PE gravatar imageArjun PE ( 2012-08-30 06:44:24 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-08-30 06:42:26 -0500

Lorenz gravatar image

I suspect you have a networking issue here. While using electric and fuerte together is not supported and definitely not recommended, it should be fine in your case because the Twist message hasn't changed for years, i.e. it should still be compatible. Try the following:

  • Start the teleop node on your PC.
  • Log into husky and do a rostopic info /husky/cmd_vel. You'll see the name of the publishers and further down information about tcp/ip connections. Find out the node name that is publishing the topic.
  • Execute rosnode info <teleop node name you just found out on husky. It will show you the host name of the publisher somewhere.
  • Try pinging the hostname of the publisher on husky. If this does not work, you know it is a network problem because husky cannot subscribe to the topic published by your pc.

Now to fix it, have a look at the networking troubleshooting page. I guess it will be sufficient if you set ROS_IP on your PC.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2012-08-30 02:27:44 -0500

Seen: 599 times

Last updated: Aug 30 '12