Ask Your Question
0

Problem with Xsens-MTIG

asked 2012-08-26 17:29:27 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Currently, Ubuntu 12.04 and Fuerte

I downloaded the cyphy_xsens_mtig package. Built all the dependencies and then cmake cyphy_xesns_mtig...No error

but when I run the node

sai@sai:~$ rosrun cyphy_xsens_mtig mtig_node file = /home/sai/fuerte_workspace/cyphy/cyphy_Drivers/cyphy_xsens_mtig/src/mtig_node.cpp line=64

Trace/breakpoint trap (core dumped)

Find the link to the code at

http://ros.informatik.uni-freiburg.de/roswiki/doc/api/cyphy_xsens_mtig/html/mtig__node_8cpp_source.html

I have edited the line 55 by changing ttyUSBxsens to ttyUSB0.

I have also connected the xsens mtig to the USB port and it is at ttyUSB0

More importantly, it worked before on ubuntu 10.04 and fuerte but later i changed to ubuntu 12.04 and fuerte with all the same settings ..and now its not working

Please let me know what i should do?

edit retag flag offensive close merge delete

Comments

1

I've had similar problems with hardware drivers on Ubuntu 12.04, it seems the new LTS version does not give the user permissions to use open virtual ports. To check if this is your problem you can simply change the permissions on your port, 'sudo chmod 777 /dev/ttyUSB0' and then try to run the node?

Gonçalo Cabrita gravatar imageGonçalo Cabrita ( 2012-08-27 01:10:11 -0600 )edit

Thank you Goncalo Cabrita ..it worked.

sai gravatar imagesai ( 2012-08-29 15:52:03 -0600 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2012-08-30 05:03:35 -0600

That is not a problem related to ROS, it is in fact a problem with Ubuntu 12.04.

You need to give your user permissions to open virtual com ports (such as for the FTDI on the XSens-MTiG):

$ sudo gedit /etc/group

And then add your username to the uucp group (change username for YOUR username):

uucp:x:10:username

And that's it! Save and close, now whenever you restart you can open any virtual com port without constantly changing the port's permissions.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2012-08-26 17:29:27 -0600

Seen: 844 times

Last updated: Aug 30 '12