Moveit_visual _tools installation error on foxy

asked 2023-02-07 23:20:38 -0600

xycotyco gravatar image

updated 2023-02-07 23:21:36 -0600

This it the error message I get when I run the command

colcon build --event-handlers desktop_notification- status- --cmake-args -DCMAKE_BUILD_TYPE=Release

output

Starting >>> graph_msgs

Starting >>> rviz_visual_tools

Finished <<< graph_msgs [0.51s]

Finished <<< rviz_visual_tools [0.57s]

Starting >>> moveit_visual_tools

--- stderr: moveit_visual_tools

/usr/bin/ld: /opt/ros/foxy/lib/librviz_common.so: undefined reference to `QTreeView::verticalScrollbarValueChanged(int)@Qt_5'

/usr/bin/ld: /opt/ros/foxy/lib/librviz_default_plugins.so: undefined reference to `qt_version_tag@Qt_5.12'

/usr/bin/ld: /opt/ros/foxy/lib/librviz_common.so: undefined reference to `QTreeWidgetItem::setHidden(bool)@Qt_5'

/usr/bin/ld: /opt/ros/foxy/lib/librviz_common.so: undefined reference to `QAbstractItemView::eventFilter(QObject, QEvent)@Qt_5'

collect2: error: ld returned 1 exit status

make[2]: * [CMakeFiles/moveit_visual_tools_demo.dir/build.make:427: moveit_visual_tools_demo] Error 1

make[1]: * [CMakeFiles/Makefile2:80: CMakeFiles/moveit_visual_tools_demo.dir/all] Error 2

make: * [Makefile:141: all] Error 2

Failed <<< moveit_visual_tools [0.90s, exited with code 2]

Summary: 2 packages finished [1.71s]

1 package failed: moveit_visual_tools

1 package had stderr output: moveit_visual_tools

1 package not processed

How do I resolve this?

edit retag flag offensive close merge delete