No topic/nodes coming through between two devices after editing NTP settings

asked 2023-01-26 09:00:26 -0500

SW gravatar image

updated 2023-01-26 09:13:20 -0500

Hi all,

I have a laptop with ubuntu 22.04 and humble. The second device is a xevior with foxy. The two devices were communicating fine, but I had some problems with incorrect timestamps. The timestamp would differ +/- 0.5 seconds. I found out this was because the NTP clocks were not synchronizing to each other. I tried to make the laptop the server and the xavier jetson the client with chrony so that the clocks would sync. This didn't work and eventually, no topics or nodes would come through. The devices can ping each other, so the connection is there. I also tried this with a third device but there were also no nodes/topics readable. What did i try:

Tried to do multicast on the laptop and that is not working. Tried the following:

sudo ufw allow in proto udp to

sudo ufw allow in proto udp from

Even disabled the firewall fully. This didn't work. I am able to read and sent topics on device one itself.

On the second device, multicast is working. This device has two dockers working together. These two dockers can send topics to each other just fine. It can also send topics to a third device and the third device can receive them.

I think the problem has to do with the firewall or with some settings in the NTP server. But I have no idea how to fix it. Does anyone know what the problem is?

edit retag flag offensive close merge delete