ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question
2

Parts are rotating with no input

asked 2023-01-22 11:55:01 -0500

aidandelli gravatar image

updated 2023-01-24 10:49:03 -0500

Hello, a team and I are attempting to build a 3-wheel holonomic drive robot in a small form factor and we are having trouble implementing our design in Gazebo. I followed a YT tutorial to convert our design in solidworks to a URDF and it seems to work fine, but once in Gazebo, the rims and rollers both rotate arbitrarily with no input. I've attached a video showing this. Does anyone know why this happens and how to make it stop?

Another thing we noticed is that the inertia values for both the rims and rollers all seem to be substantially lower than they should be (like 1000x+ off). Is this common? How could we fix this too without doing all the calculations manually and overriding them?

EDIT: I don't have 5 karma so I can't upload any files but would still appreciate any possible insight.

edit retag flag offensive close merge delete

Comments

I upvoted your question, it gave you +10 karma, please add your file. My first thought is a gravity force on the robot. What plugins do you use in the robot model?

ljaniec gravatar image ljaniec  ( 2023-01-22 19:59:30 -0500 )edit

I've tried linking the video like 10x and compressing it and cutting it to be smaller but it still won't upload. Any idea why this is happening or is it just because my account is so new? Here is a link to it to watch online: https://clipchamp.com/watch/4irvim73rKY

In Gazebo, we are in an empty world and only using ros2_control plugin.

aidandelli gravatar image aidandelli  ( 2023-01-23 08:25:26 -0500 )edit

I never tried to upload a video here, I only saw links to a YouTube or Vimeo etc. Maybe you could add a few screens instead? For people checking this answer on the phone etc. Maybe someone could tell more about it.

ljaniec gravatar image ljaniec  ( 2023-01-23 21:01:52 -0500 )edit

I linked the vid in the comment above (Clipchamp) so you can see it rotating.

aidandelli gravatar image aidandelli  ( 2023-01-24 10:19:21 -0500 )edit
1

1000x off sounds like a units mismatch. Check the units in the SW URDF exporter and in your SW file.

achille gravatar image achille  ( 2023-01-24 16:48:57 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2023-01-23 21:10:13 -0500

ljaniec gravatar image

Based on the video - it looks like it could be a jittering (based on this) - others pointed out that incorrect inertial values could be the reason.

Can you try to remove model parts one by one and check if the model stays in place after it?

I don't know the SolidWorks software, but usually there is an option to choose the material and get inertial values directly from it.

If this is not possible, maybe you could do a rough estimation of it based on the cylinders containing each part? It must be done by hand, I am afraid. You could probably try to use this SDF Builder to calculate simpler basic shapes (box/cylinder/sphere).

edit flag offensive delete link more
0

answered 2023-02-06 01:49:25 -0500

Davies Ogunsina gravatar image

updated 2023-02-06 01:52:51 -0500

The problem is in your urdf , .gazebo file , try and change the <mu1> tag to 1500 and that of <mu2> set the gravity tag to true.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2023-01-22 11:50:20 -0500

Seen: 172 times

Last updated: Feb 06 '23