ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A answers.ros.org
Ask Your Question
0

Could NOT find combined_robot_hw (missing: combined_robot_hw_DIR)

asked 2022-11-04 16:04:31 -0600

akumar3.1428 gravatar image

updated 2022-11-04 16:04:46 -0600

Hi, I tried cloning the repository following the instruction on the master branch (https://github.com/xArm-Developer/xar...), however while doing catkin_make I am getting the following error, please help me through this. I feel like something is wrong with the controller package on their github.

```
-- Could NOT find combined_robot_hw (missing: combined_robot_hw_DIR)
-- Could not find the required component 'combined_robot_hw'. The following CMake error indicates that you either need to install the package with the same name or change your environment so that it can be found.
CMake Error at /opt/ros/noetic/share/catkin/cmake/catkinConfig.cmake:83 (find_package):
  Could not find a package configuration file provided by "combined_robot_hw"
  with any of the following names:

    combined_robot_hwConfig.cmake
    combined_robot_hw-config.cmake

  Add the installation prefix of "combined_robot_hw" to CMAKE_PREFIX_PATH or
  set "combined_robot_hw_DIR" to a directory containing one of the above
  files.  If "combined_robot_hw" provides a separate development package or
  SDK, be sure it has been installed.
Call Stack (most recent call first):
  xarm_ros/xarm_controller/CMakeLists.txt:12 (find_package)


-- Configuring incomplete, errors occurred!
See also "/home/akumar/catkin_ws/build/CMakeFiles/CMakeOutput.log".
See also "/home/akumar/catkin_ws/build/CMakeFiles/CMakeError.log".

```
edit retag flag offensive close merge delete

Comments

I feel like something is wrong with the controller package on their github.

let's not jump to conclusions too quick.

Did you follow the steps in the Install other dependent packages section of the readme?

gvdhoorn gravatar image gvdhoorn  ( 2022-11-05 02:45:02 -0600 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2022-11-05 07:48:07 -0600

ravijoshi gravatar image

As @gvdhoorn has pointed out, it seems that you have not installed dependencies. Please follow the documentation carefully.

For the error mentioned above, the combined-robot-hw package can be installed with the following command:

sudo apt install ros-noetic-combined-robot-hw
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2022-11-04 16:04:31 -0600

Seen: 52 times

Last updated: Nov 05 '22