hector_slam hokuyo_node MultipleMachines Problem [closed]

asked 2012-08-07 23:06:53 -0500

Tirgo gravatar image

updated 2012-08-08 00:33:04 -0500

EDIT: FIXED IT.

I just had to start the static_transform_publisher on my pandaboard instead of my PC. Feel a bit stupid right now. :)

Hi all

I'm currently working with hector_slam and the hokuyo_node to create some maps without odom. My goal is to run around with the hokuyo laser connected to a pandaboard. (with ubunutu and ros installed). On my main pc i have installed ubuntu 12.04 and ros fuerte. I want to read out the scan data over a wireless network and create then a map with hector_slam on my main PC.

If i connect the laser to my main PC, i can create maps with hokuyo_node and hector_slam running on it.

If i run the hokuyo_node on my pandaboard i can watch the laserscan in rviz on my main PC with the frame /laser.

But if i connect the laser to my Pandaboard and run the hokuyo node on it, the hector_slam on my main PC is not able to work with it and i really don't get it why.

So here is my launchfile for hector_slam which works great if i start everything on my main PC. I don't even have to unlog my main PC out of the multiple machine network settings.

<launch>

<node pkg="hector_mapping" type="hector_mapping" name="hector_mapping" output="screen">

<param name="base_frame" value="base_link"/>
<param name="odom_frame" value="base_link"/>
<param name="pub_map_odom_transform" value="true"/>
<param name="scan_subscriber_queue_size" value="25"/>

<!-- Map size / start point -->
<param name="map_resolution" value="0.050"/>
<param name="map_size" value="2048"/>
<param name="map_start_x" value="0.5"/>
<param name="map_start_y" value="0.5" />
<param name="map_multi_res_levels" value="2" />

</node>

<include file="$(find hector_geotiff)/launch/geotiff_mapper.launch"> </include>

<node pkg="tf" type="static_transform_publisher" name="map_nav_broadcaster" args="0 0 0 0 0 0 base_link laser 100"/>

</launch>

If i try to run the hokuyo-Laser on the pandaboard hector_slam says:

INFO] [1344415605.856836900]: lookupTransform base_link to laser timed out. Could not transform laser scan into base_frame.

I'm a bit confused and would appreciate some help. I don't understand why i it works perfect when i start everything on my main PC. If i start the laser on my pandaboard the scan-data is published, but hector_slam doesn't work.

I add 2 screenshots of rosrun tf view_frames

http://s7.directupload.net/file/d/2976/ymqwfsoh_png.htm with pandaboard http://s14.directupload.net/file/d/2976/si54gyi4_png.htm with PC only

EDIT1:

One Edit if i run the hokuyo_node on my pandaboard on look at the laserscan in rviz on my main pc i get the warning:

WARN] [1344420846.194282425]: Message from [/hokuyo_node] has a non-fully-qualified frame_id [laser]. Resolved locally to [/laser]. This is will likely not work in multi-robot systems. This message will only print once.

I don't get this warning if i run both (laser and laserscan in rviz on my main pc) I will go on and try to fix this warning maybe it causes my errors. Perhaps someone already knows how to fix it? :)

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2015-04-05 20:38:52.815699